Jump to content
  • Advertisement
Sign in to follow this  
me_here_me

OpenGL creating an exe

This topic is 4075 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi My applciation coded in OpenGL an using GLSL as well does not produce a working exe. The exe that is produced by the build process works in an unknown manner. The program works fine when run from the VS.net IDE, but produces crap images when run directly from the exe!! any hints on this

Share this post


Link to post
Share on other sites
Advertisement
When you run the exe from the IDE, it sets the working directory to that of your project (or solution, I can't recall offhand). When you run the exe directly from explorer, it sets the working directory to the directory the exe is in.

So any resource loading functions will try to load resources from a different directory unless you exploicitly specify a directory or move the exe. Of course, because you're checking all your return values, this doesn't happen, does it?

Share this post


Link to post
Share on other sites
All the necessary files are in that folder containing the exe. But the images look different when run from these two location. i am surprised !!


Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!