Jump to content
  • Advertisement
Sign in to follow this  
Funkyjive

OpenGL GL_TEXTURE_MIN_FILTER Problem

This topic is 4103 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am having a few problems getting texture mapping into my game. Being a relative newbie to opengl I decided to encompass all of the texture things into a single easy to use class called Texture. I added everything and tested it out. After trying many things I got my problem down to a single line of code. glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER, GL_LINEAR); When this line is in place the texture gets aplied and shows up fine however my simple test program slows to a crawl. I only have 1 textured object so I dont believe the problem is with having to much to render. When the line is commented out the test program runs at the normall speed however the textured object is just plain white. I did some searching and found something about minification and how it might not be a compleate mipmap or something but I couldn't figure it out. Here is the class definition... Texture.h http://rafb.net/p/JDAcPJ74.html Texture.cpp http://rafb.net/p/5xqnWi75.html Thank You!!

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!