Jump to content
  • Advertisement
Sign in to follow this  
k-otik

viewport flickering

This topic is 4076 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, I'm experiencing some trouble while working with viewports. First of all, i cleared the whole backbuffer and then i set two viewports. I clear each one before any rendering and that works fine in windowed mode. But in fullscreen mode, the both area are filled by flickering window background. I have seen that the problem can be solved by changing the swapeffect, initially set to D3DSWAPEFFECT_DISCARD, to D3DSWAPEFFECT_COPY. But D3DSWAPEFFECT_COPY is known to have some performance drawback. Do you know any other way to solve that ? Thanks, and sorry for my english.

Share this post


Link to post
Share on other sites
Advertisement
I have just solved my problem. As i use a pair of Render->StartDraw() and Render->EndDraw() functions, i totally forget than i call twice the present directX function so..
I solved my problem, in using triple buffering and understanding why that worked fine with.

Thank.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!