Sign in to follow this  

SDL and Vista

This topic is 3845 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm getting started with SDL, and have written a simple app that draws a white triangle to the screen using OpenGL. Problem is on Vista, the program leaks memory like a sieve according to the task manager. On XP however, the program holds steady at a little over 2MB. I'm building with Visual Studio 2005 with SDL 1.2.11 on each system. I've heard the task manager is not to be trusted, but something about this just doesn't look right. Does anyone have any ideas?

Share this post


Link to post
Share on other sites
Where in the task manager does it show this leaking? I guess I never seen it or knew there was way to check that... AFAIK I am not having any issues with SDL on Vista Ultimate 32bit.

Share this post


Link to post
Share on other sites
It looks like I might have spoke too soon. The Memory (Private Working Set) column on the Processes page of the task manager reports the memory usage starting off around 4,800K and it slowly crawls up to around 5,700K where it seems to stabilize. I know Vista's memory usage is dramatically different from XP's so I'm guessing this is normal.

Share this post


Link to post
Share on other sites

This topic is 3845 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this