Sign in to follow this  
Spazmodan

Uhh.. [hammer ambient light problems]

Recommended Posts

Okay, I have no idea where I should post this but I noticed some people talking about Half-Life 2 and something with the editor, O.o (Since I searched some keywords into google) and I guess i'll just post it here... I got a question dealing with the editor in Half-Life 2. Source SDK - Hammer Editor. I watched some tutorials on how to make a basic room and the person making the room said to place a light over in the corner, otherwise if you ran the level it would be pitch black. I did that, loaded up my map, and it was PURE bright, no darkness at all. I took out the light, loaded it up again, and it was still PURE bright...Is it possible to make these areas inside completely dark?! Edit by Rav: Please use a more descriptive post title. [Edited by - Ravuya on June 6, 2007 11:05:55 AM]

Share this post


Link to post
Share on other sites
I tried a basic map, and the problem you described did occur. The problem is with the basic lighting used in levels. If you don't put any lights in, a setting called mat_fullbright is set to 1 by default (which makes everything equally bright). So when you enter a level without a light, you can change that setting in the console to manually turn off the light.

On the other hand, when you place a light entity in the level, the default settings of the light may very well resemble that of mat_fullbright. When you bring up the light's properties (double click with Selection Tool), you can change the brightness setting (play around with it. setting the last number to 0 makes the light emit 0 light. This is useful in stopping the mat_fullbright from defaulting, so you may want to create a dummy light and place it in a far off place just to make the level start out without lighting), as well as some other settings you can change (there are some cool things in the appearance tab, such as pulsing lights).

Sorry if I'm unclear or got the explanation wrong. I'm a newbie in designing levels for Half Life 2, too, so I'm learning the ropes just like you.

Share this post


Link to post
Share on other sites
I figured it a different way. On flags of the light you can select "Initially dark" and it seemed to work out for me in-game. I have encountered another problem, though. The monsters that are in the pitch black areas of the room are completely visible instead of actually be hidden in the dark. Is there some way I can fix that?

Share this post


Link to post
Share on other sites
I can't say I know (I haven't even started playing with NPC's yet). You may want to try this site: http://www.interlopers.net/forum/ . They have tons of information on Half-Life 2 level design, and could probably easily answer your question. Sorry I couldn't be more helpful.

edit: Thanks for teaching me about the initially dark flag. I had not noticed that. It's much more useful than creating a dummy light. So thanks!

Share this post


Link to post
Share on other sites
IIRC, you need to run "buildcubemaps" from the in-game console to fix the problem with enemies being visible in the dark. I don't know if you need to place an env_cubemap entity or not. Source might generate one automatically during a compile.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this