• Advertisement
Sign in to follow this  

How to render HAIR

This topic is 3871 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi All, i want render Hair in Direct3D the same MAYA, can? pls see link : Free Image Hosting by FreeImageHosting.net, anybody have ideas, think, can share with me, thanks very much. David, [Edited by - thuong on June 18, 2007 2:04:13 AM]

Share this post


Link to post
Share on other sites
Advertisement
Looks like a few triangles with a hair texture on them, and alpha at the end. Have you tried anything like that?

Share this post


Link to post
Share on other sites
Hi Evil Steve,
Thanks very much

I had try enable alpha transparent, blending but it bad, can you help me, how to set alpha transparent and alpha blending good?

David,

Share this post


Link to post
Share on other sites
thuong,

Can you show us a screenshot of how it looks "bad". Maybe then we can provide better suggestions.

Share this post


Link to post
Share on other sites
Hi honayboyz,
Thanks very much,

Following is capture image from my rendering:

Free Image Hosting by FreeImageHosting.net

Free Image Hosting by FreeImageHosting.net

[Edited by - thuong on June 17, 2007 11:05:19 PM]

Share this post


Link to post
Share on other sites
From that picture, it looks like you have alpha testing enabled, but not alpha blending.

Copy&Pasted from a tutorial I found with google:
m_pDirect3DDevice->SetRenderState(D3DRS_ALPHABLENDENABLE,true);		//alpha blending enabled
m_pDirect3DDevice->SetRenderState(D3DRS_SRCBLEND,D3DBLEND_SRCALPHA); //source blend factor
m_pDirect3DDevice->SetRenderState(D3DRS_DESTBLEND,D3DBLEND_INVSRCALPHA); //destination blend factor

m_pDirect3DDevice->SetTextureStageState(0,D3DTSS_ALPHAARG1,D3DTA_TEXTURE); //alpha from texture

Share this post


Link to post
Share on other sites
Hi Hodgman,
Thanks very much,

Yes, you are correct, i just enable testing alpha, i will try to enable blending alpha.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement