Jump to content
  • Advertisement
Sign in to follow this  
Imp3

SDL rotozoomSurface - strange behavior

This topic is 4107 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey, I searched for a way to do Bitmap Rotating with SDL. I then found this Thread: http://www.gamedev.net/community/forums/topic.asp?topic_id=381538 which helped alot. But the rotate ends up in a strange jumping here is a small video: http://m0hr.de/rotozoomSurface.avi Here's the Surface: http://m0hr.de/ship.bmp And the code (C++) Snippet: void rot_left() { rotation -= 1; actual = rotozoomSurface (image, (2.25*rotation), 1, 0); if (rotation < 0) rotation = 159; return; } The functions is toggled when I push left button, "rotation" is an int going from 0-159 as i need the angle for rotozoomsurface I multiply it by 2.25 to get an in from 0-359. Why is my Sprite bouncing like that? Has it something to do with the underliing Algorithm? Thx for help.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!