Jump to content
  • Advertisement
Sign in to follow this  
SticksandStones

Getting Ubuntu to work with WPA-PSK

This topic is 4165 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I can not for the life of me get Ubuntu to connect to my wireless router when I have WPA-PSK security enabled. If I disable it it connects fine, but it will not let me connect otherwise. It seems that this is a common problem, so surely someone out there has tried something that has worked. Any suggestions?

Share this post


Link to post
Share on other sites
Advertisement
What kind of card and router do you have? What driver are you using for the card? What version of Ubuntu?

Moved to Everything Unix.

Share this post


Link to post
Share on other sites
Quote:
Original post by Ravuya
What kind of card and router do you have? What driver are you using for the card? What version of Ubuntu?

Moved to Everything Unix.


I wasn't sure if this would fit in Everything Unix, sorry for making you move it [smile]

I'm on an Intel PROSet/Wireless 3945ABG wireless card, attempting to connect to a Belkin 802.11G router (if you need more specific let me know). I'm unsure of the driver, I believe the default wireless driver of the distro, and I'm running Edgy (6.10).

Share this post


Link to post
Share on other sites
Quote:
Original post by Null and Void
This guide discusses how to enable WPA manually. It is the guide I successfully followed when I last setup WPA Supplicant on my notebook.


Tried it, it doesn't work. When I do:

sudo wpa_supplicant -ieth1 -c/etc/wpa_supplicant.conf -Dmadwifi -w

all I get is a bunch of a errors.

Share this post


Link to post
Share on other sites
Quote:
Original post by SticksandStones
Quote:
Original post by Null and Void
This guide discusses how to enable WPA manually. It is the guide I successfully followed when I last setup WPA Supplicant on my notebook.


Tried it, it doesn't work. When I do:

sudo wpa_supplicant -ieth1 -c/etc/wpa_supplicant.conf -Dmadwifi -w

all I get is a bunch of a errors.


It would help if you would POST the errors, since we cannot guess which of the errors you're getting, and therefor cannot anticipate on them.

Toolmaker

Share this post


Link to post
Share on other sites
Quote:
Original post by Toolmaker
Quote:
Original post by SticksandStones
Quote:
Original post by Null and Void
This guide discusses how to enable WPA manually. It is the guide I successfully followed when I last setup WPA Supplicant on my notebook.


Tried it, it doesn't work. When I do:

sudo wpa_supplicant -ieth1 -c/etc/wpa_supplicant.conf -Dmadwifi -w

all I get is a bunch of a errors.


It would help if you would POST the errors, since we cannot guess which of the errors you're getting, and therefor cannot anticipate on them.

Toolmaker


I wasn't at my computer at the time so I COULDN'T post them.

Share this post


Link to post
Share on other sites
benny@benny-laptop:~$ sudo wpa_supplicant -ieth1 -c/etc/wpa_supplicant.conf -Dmadwifi -w
ioctl[IEEE80211_IOCTL_DELKEY]: Operation not supported
ioctl[IEEE80211_IOCTL_DELKEY]: Operation not supported
ioctl[IEEE80211_IOCTL_DELKEY]: Operation not supported
ioctl[IEEE80211_IOCTL_DELKEY]: Operation not supported
CTRL-EVENT-TERMINATING - signal 2 received
ioctl[IEEE80211_IOCTL_SETOPTIE]: Operation not supported

That's what I get when I try to follow the guide. Any suggestions?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!