Jump to content
  • Advertisement
Sign in to follow this  
carlsfinch

Getting the Xbox360 controller to work in linux?

This topic is 4156 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I followed the instructions at http://gentoo-wiki.com/HOWTO_Xbox_360_controller_on_Linux and step by step this is what I got. if you can make sense out of it here is exactly what i typed in my terminal what happend, and what errors I got.
carl@ubuntu7:~$ sudo apt-get install linux-headers-´uname -r´ build-essential
Password:
E: Command line option 'r' [from -r´] is not known.
carl@ubuntu7:~$ sudo apt-get install automake1.9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
automake1.9 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 67 not upgraded.
carl@ubuntu7:~$ gedit ~./.xpa360/Makefile

** (gedit:11477): WARNING **: Hit unhandled case 1 (File not found) in gedit_unrecoverable_saving_error_message_area_new.
carl@ubuntu7:~$ cd /home/carl/.xpad360
carl@ubuntu7:~/.xpad360$ sudo make
make modules -C /usr/src/linux-headers-2.6.20-15-generic SUBDIRS=/home/carl/.xpad360
make[1]: Entering directory `/usr/src/linux-headers-2.6.20-15-generic'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-15-generic'
carl@ubuntu7:~/.xpad360$ sudo cp xpad.ko /lib/modules/$(uname -r)/kernel/drivers/usb/input
carl@ubuntu7:~/.xpad360$ sudo depmod -a
sudo modprobe xpad
sudo shutown -r 1
carl@ubuntu7:~/.xpad360$ sudo modprobe xpad
carl@ubuntu7:~/.xpad360$ sudo shutown -r 1
sudo: shutown: command not found
carl@ubuntu7:~/.xpad360$ 


Also, it said to type in dmesg and look at input 6 it should say Microsoft Xbox360 controller but it doesn´t and I also found that i got more errors than just the xbox controller, so here it is. Hope you can make sense of it. I can barely make sense of it, but also I am quite new to linux.
carl@ubuntu7:~$ dmesg
[    0.000000] Linux version 2.6.20-15-generic (root@palmer) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Sun Apr 15 07:36:31 UTC 2007 (Ubuntu 2.6.20-15.27-generic)
[    0.000000] BIOS-provided physical RAM map:
[    0.000000] sanitize start
[    0.000000] sanitize end
[    0.000000] copy_e820_map() start: 0000000000000000 size: 000000000009f800 end: 000000000009f800 type: 1
[    0.000000] copy_e820_map() type is E820_RAM
[    0.000000] copy_e820_map() start: 000000000009f800 size: 0000000000000800 end: 00000000000a0000 type: 2
[    0.000000] copy_e820_map() start: 00000000000ce000 size: 0000000000002000 end: 00000000000d0000 type: 2
[    0.000000] copy_e820_map() start: 00000000000dc000 size: 0000000000024000 end: 0000000000100000 type: 2
[    0.000000] copy_e820_map() start: 0000000000100000 size: 000000000dde0000 end: 000000000dee0000 type: 1
[    0.000000] copy_e820_map() type is E820_RAM
[    0.000000] copy_e820_map() start: 000000000dee0000 size: 000000000000b000 end: 000000000deeb000 type: 3
[    0.000000] copy_e820_map() start: 000000000deeb000 size: 0000000000015000 end: 000000000df00000 type: 4
[    0.000000] copy_e820_map() start: 000000000df00000 size: 0000000002100000 end: 0000000010000000 type: 2
[    0.000000] copy_e820_map() start: 00000000ff800000 size: 0000000000400000 end: 00000000ffc00000 type: 2
[    0.000000] copy_e820_map() start: 00000000fffffc00 size: 0000000000000400 end: 0000000100000000 type: 2
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
[    0.000000]  BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000ce000 - 00000000000d0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000dc000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000000dee0000 (usable)
[    0.000000]  BIOS-e820: 000000000dee0000 - 000000000deeb000 (ACPI data)
[    0.000000]  BIOS-e820: 000000000deeb000 - 000000000df00000 (ACPI NVS)
[    0.000000]  BIOS-e820: 000000000df00000 - 0000000010000000 (reserved)
[    0.000000]  BIOS-e820: 00000000ff800000 - 00000000ffc00000 (reserved)
[    0.000000]  BIOS-e820: 00000000fffffc00 - 0000000100000000 (reserved)
[    0.000000] 0MB HIGHMEM available.
[    0.000000] 222MB LOWMEM available.
[    0.000000] Entering add_active_range(0, 0, 57056) 0 entries of 256 used
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA             0 ->     4096
[    0.000000]   Normal       4096 ->    57056
[    0.000000]   HighMem     57056 ->    57056
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0:        0 ->    57056
[    0.000000] On node 0 totalpages: 57056
[    0.000000]   DMA zone: 32 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 4064 pages, LIFO batch:0
[    0.000000]   Normal zone: 413 pages used for memmap
[    0.000000]   Normal zone: 52547 pages, LIFO batch:15
[    0.000000]   HighMem zone: 0 pages used for memmap
[    0.000000] DMI present.
[    0.000000] ACPI: RSDP (v000 PTLTD                                 ) @ 0x000f7780
[    0.000000] ACPI: RSDT (v001 PTLTD  ManiaDth 0x06040000  LTP 0x00000000) @ 0x0dee69cd
[    0.000000] ACPI: FADT (v001 INTEL  MONTARA  0x06040000 PTL  0x00000050) @ 0x0deeaec4
[    0.000000] ACPI: BOOT (v001 PTLTD  $SBFTBL$ 0x06040000  LTP 0x00000001) @ 0x0deeafd8
[    0.000000] ACPI: SSDT (v001 INTEL  CPU0CST  0x00000001 INTL 0x20030224) @ 0x0dee6dfd
[    0.000000] ACPI: DSDT (v001 INTEL  MONTARAG 0x06040000 MSFT 0x0100000e) @ 0x00000000
[    0.000000] ACPI: PM-Timer IO Port: 0x1008
[    0.000000] Allocating PCI resources starting at 20000000 (gap: 10000000:ef800000)
[    0.000000] Detected 1395.501 MHz processor.
[   11.114853] Built 1 zonelists.  Total pages: 56611
[   11.114858] Kernel command line: root=UUID=d75ef2cc-b260-4442-8993-c101c1eed966 ro quiet splash
[   11.115055] Local APIC disabled by BIOS -- you can enable it with "lapic"
[   11.115063] mapped APIC to ffffd000 (011ca000)
[   11.115067] Enabling fast FPU save and restore... done.
[   11.115070] Enabling unmasked SIMD FPU exception support... done.
[   11.115081] Initializing CPU#0
[   11.115164] PID hash table entries: 1024 (order: 10, 4096 bytes)
[   11.117068] Console: colour VGA+ 80x25
[   11.117182] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[   11.117296] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[   11.125243] Memory: 215232k/228224k available (1992k kernel code, 12472k reserved, 893k data, 328k init, 0k highmem)
[   11.125255] virtual kernel memory layout:
[   11.125256]     fixmap  : 0xfff4e000 - 0xfffff000   ( 708 kB)
[   11.125258]     pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
[   11.125259]     vmalloc : 0xce800000 - 0xff7fe000   ( 783 MB)
[   11.125261]     lowmem  : 0xc0000000 - 0xcdee0000   ( 222 MB)
[   11.125263]       .init : 0xc03d7000 - 0xc0429000   ( 328 kB)
[   11.125264]       .data : 0xc02f2264 - 0xc03d16d4   ( 893 kB)
[   11.125266]       .text : 0xc0100000 - 0xc02f2264   (1992 kB)
[   11.125270] Checking if this processor honours the WP bit even in supervisor mode... Ok.
[   11.203077] Calibrating delay using timer specific routine.. 2792.89 BogoMIPS (lpj=5585799)
[   11.203127] Security Framework v1.0.0 initialized
[   11.203137] SELinux:  Disabled at boot.
[   11.203157] Mount-cache hash table entries: 512
[   11.203325] CPU: After generic identify, caps: afe9f9ff 00100000 00000000 00000000 00000000 00000000 00000000
[   11.203339] CPU: L1 I cache: 32K, L1 D cache: 32K
[   11.203342] CPU: L2 cache: 1024K
[   11.203345] CPU: After all inits, caps: afe9f9ff 00100000 00000000 00002040 00000000 00000000 00000000
[   11.203356] Compat vDSO mapped to ffffe000.
[   11.203362] Remapping vsyscall page to ffffe000
[   11.203375] Checking 'hlt' instruction... OK.
[   11.219163] SMP alternatives: switching to UP code
[   11.219351] Freeing SMP alternatives: 11k freed
[   11.219559] Early unpacking initramfs... done
[   11.615259] ACPI: Core revision 20060707
[   11.615652] ACPI: Looking for DSDT in initramfs... file /DSDT.aml not found, using machine DSDT.
[   11.617347] ACPI: setting ELCR to 0200 (from 0c28)
[   11.625121] CPU0: Intel(R) Celeron(R) M processor         1.40GHz stepping 08
[   11.625128] SMP motherboard not detected.
[   11.625131] Local APIC not detected. Using dummy APIC emulation.
[   11.625170] Brought up 1 CPUs
[   11.625448] Booting paravirtualized kernel on bare hardware
[   11.625529] Time:  4:29:26  Date: 05/24/107
[   11.625562] NET: Registered protocol family 16
[   11.625661] EISA bus registered
[   11.625666] ACPI: bus type pci registered
[   11.626046] PCI: PCI BIOS revision 2.10 entry at 0xfd932, last bus=2
[   11.626049] PCI: Using configuration type 1
[   11.626051] Setting up standard PCI resources
[   11.635307] ACPI: Interpreter enabled
[   11.635310] ACPI: Using PIC for interrupt routing
[   11.636100] ACPI: PCI Root Bridge [PCI0] (0000:00)
[   11.636106] PCI: Probing PCI hardware (bus 00)
[   11.637083] Boot video device is 0000:00:02.0
[   11.637386] PCI quirk: region 1000-107f claimed by ICH4 ACPI/GPIO/TCO
[   11.637390] PCI quirk: region 1180-11bf claimed by ICH4 GPIO
[   11.637781] PCI: Transparent bridge - 0000:00:1e.0
[   11.637843] PCI: Bus #03 (-#06) is hidden behind transparent bridge #02 (-#02) (try 'pci=assign-busses')
[   11.637846] Please report the result to linux-kernel to fix this permanently
[   11.637895] PCI: Bus #07 (-#0a) is hidden behind transparent bridge #02 (-#02) (try 'pci=assign-busses')
[   11.637898] Please report the result to linux-kernel to fix this permanently
[   11.637915] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[   11.640666] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCIB._PRT]
[   11.641781] ACPI: PCI Interrupt Link [LNKA] (IRQs *5)
[   11.642014] ACPI: PCI Interrupt Link [LNKB] (IRQs *10)
[   11.642244] ACPI: PCI Interrupt Link [LNKC] (IRQs *10)
[   11.642473] ACPI: PCI Interrupt Link [LNKD] (IRQs *11)
[   11.642714] ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 4 5 6 7 10 12 14 15) *0, disabled.
[   11.642948] ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 4 5 6 7 11 12 14 15) *0, disabled.
[   11.643180] ACPI: PCI Interrupt Link [LNKG] (IRQs 1 3 4 5 6 7 10 12 14 15) *0, disabled.
[   11.643415] ACPI: PCI Interrupt Link [LNKH] (IRQs 1 *3 4 5 6 7 11 12 14 15)
[   11.644812] Linux Plug and Play Support v0.97 (c) Adam Belay
[   11.644831] pnp: PnP ACPI init
[   11.647107] pnp: PnP ACPI: found 8 devices
[   11.647112] PnPBIOS: Disabled by ACPI PNP
[   11.647166] PCI: Using ACPI for IRQ routing
[   11.647170] PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
[   11.652678] NET: Registered protocol family 8
[   11.652681] NET: Registered protocol family 20
[   11.653065] PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
[   11.653085] PCI: Bus 3, cardbus bridge: 0000:02:07.0
[   11.653088]   IO window: 00003400-000034ff
[   11.653092]   IO window: 00003800-000038ff
[   11.653097]   PREFETCH window: 20000000-23ffffff
[   11.653101]   MEM window: 2c000000-2fffffff
[   11.653105] PCI: Bus 7, cardbus bridge: 0000:02:07.1
[   11.653108]   IO window: 00003c00-00003cff
[   11.653112]   IO window: 00001400-000014ff
[   11.653116]   PREFETCH window: 24000000-27ffffff
[   11.653121]   MEM window: 30000000-33ffffff
[   11.653124] PCI: Bridge: 0000:00:1e.0
[   11.653127]   IO window: 3000-3fff
[   11.653133]   MEM window: e0200000-e02fffff
[   11.653138]   PREFETCH window: 20000000-27ffffff
[   11.653151] PCI: Setting latency timer of device 0000:00:1e.0 to 64
[   11.653346] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
[   11.653349] PCI: setting IRQ 11 as level-triggered
[   11.653353] ACPI: PCI Interrupt 0000:02:07.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
[   11.653361] PCI: Setting latency timer of device 0000:02:07.0 to 64
[   11.653533] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
[   11.653536] PCI: setting IRQ 10 as level-triggered
[   11.653540] ACPI: PCI Interrupt 0000:02:07.1 -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
[   11.653547] PCI: Setting latency timer of device 0000:02:07.1 to 64
[   11.653578] NET: Registered protocol family 2
[   11.690639] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[   11.690727] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[   11.690794] TCP bind hash table entries: 4096 (order: 3, 32768 bytes)
[   11.690828] TCP: Hash tables configured (established 8192 bind 4096)
[   11.690832] TCP reno registered
[   11.702693] checking if image is initramfs... it is
[   12.490464] Freeing initrd memory: 6781k freed
[   12.490758] Simple Boot Flag at 0x36 set to 0x1
[   12.490975] audit: initializing netlink socket (disabled)
[   12.490996] audit(1182659366.556:1): initialized
[   12.491152] VFS: Disk quotas dquot_6.5.1
[   12.491175] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[   12.491234] io scheduler noop registered
[   12.491237] io scheduler anticipatory registered
[   12.491240] io scheduler deadline registered
[   12.491252] io scheduler cfq registered (default)
[   12.491714] isapnp: Scanning for PnP cards...
[   12.845166] isapnp: No Plug & Play device found
[   12.879152] Real Time Clock Driver v1.12ac
[   12.879217] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[   12.880082] ACPI: PCI Interrupt 0000:00:1f.6 -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
[   12.880093] ACPI: PCI interrupt for device 0000:00:1f.6 disabled
[   12.880174] mice: PS/2 mouse device common for all mice
[   12.880832] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024 blocksize
[   12.881122] input: Macintosh mouse button emulation as /class/input/input0
[   12.881161] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
[   12.881166] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[   12.881457] PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[   12.885145] serio: i8042 KBD port at 0x60,0x64 irq 1
[   12.885151] serio: i8042 AUX port at 0x60,0x64 irq 12
[   12.885302] EISA: Probing bus 0 at eisa.0
[   12.885311] Cannot allocate resource for EISA slot 1
[   12.885315] Cannot allocate resource for EISA slot 2
[   12.885318] Cannot allocate resource for EISA slot 3
[   12.885351] EISA: Detected 0 cards.
[   12.915436] TCP cubic registered
[   12.915445] NET: Registered protocol family 1
[   12.915471] Using IPI No-Shortcut mode
[   12.915551] ACPI: (supports S0 S3 S4 S5)
[   12.915600]   Magic number: 11:151:465
[   12.915987] Freeing unused kernel memory: 328k freed
[   12.917302] Time: tsc clocksource has been installed.
[   13.101640] input: AT Translated Set 2 keyboard as /class/input/input1
[   14.154157] Capability LSM initialized
[   14.193656] ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
[   14.193664] ACPI: Processor [CPU0] (supports 8 throttling states)
[   14.194929] ACPI: Thermal Zone [THRM] (77 C)
[   14.622491] usbcore: registered new interface driver usbfs
[   14.622516] usbcore: registered new interface driver hub
[   14.622539] usbcore: registered new device driver usb
[   14.623541] USB Universal Host Controller Interface driver v3.0
[   14.623845] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
[   14.623849] PCI: setting IRQ 5 as level-triggered
[   14.623853] ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link [LNKA] -> GSI 5 (level, low) -> IRQ 5
[   14.623865] PCI: Setting latency timer of device 0000:00:1d.0 to 64
[   14.623870] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[   14.624074] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
[   14.624098] uhci_hcd 0000:00:1d.0: irq 5, io base 0x00001820
[   14.624212] usb usb1: configuration #1 chosen from 1 choice
[   14.624240] hub 1-0:1.0: USB hub found
[   14.624246] hub 1-0:1.0: 2 ports detected
[   14.684596] SCSI subsystem initialized
[   14.690891] libata version 2.20 loaded.
[   14.727603] ACPI: PCI Interrupt 0000:00:1d.1 -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
[   14.727619] PCI: Setting latency timer of device 0000:00:1d.1 to 64
[   14.727624] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[   14.727650] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
[   14.727676] uhci_hcd 0000:00:1d.1: irq 11, io base 0x00001840
[   14.727780] usb usb2: configuration #1 chosen from 1 choice
[   14.727808] hub 2-0:1.0: USB hub found
[   14.727815] hub 2-0:1.0: 2 ports detected
[   14.773203] ieee1394: Initialized config rom entry `ip1394'
[   14.786999] 8139too Fast Ethernet driver 0.9.28
[   14.831752] ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 10
[   14.831758] ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
[   14.831772] PCI: Setting latency timer of device 0000:00:1d.2 to 64
[   14.831776] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[   14.831804] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
[   14.831830] uhci_hcd 0000:00:1d.2: irq 10, io base 0x00001860
[   14.831936] usb usb3: configuration #1 chosen from 1 choice
[   14.831969] hub 3-0:1.0: USB hub found
[   14.831976] hub 3-0:1.0: 2 ports detected
[   14.937076] ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 3
[   14.937082] PCI: setting IRQ 3 as level-triggered
[   14.937086] ACPI: PCI Interrupt 0000:00:1d.7[D] -> Link [LNKH] -> GSI 3 (level, low) -> IRQ 3
[   14.937104] PCI: Setting latency timer of device 0000:00:1d.7 to 64
[   14.937109] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[   14.937157] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 4
[   14.937194] ehci_hcd 0000:00:1d.7: debug port 1
[   14.937200] PCI: cache line size of 32 is not supported by device 0000:00:1d.7
[   14.937211] ehci_hcd 0000:00:1d.7: irq 3, io mem 0xe0100000
[   14.941078] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[   14.941193] usb usb4: configuration #1 chosen from 1 choice
[   14.941224] hub 4-0:1.0: USB hub found
[   14.941232] hub 4-0:1.0: 6 ports detected
[   14.967210] usb 1-2: new full speed USB device using uhci_hcd and address 2
[    3.888000] Time: acpi_pm clocksource has been installed.
[    3.928000] ata_piix 0000:00:1f.1: version 2.10ac1
[    3.928000] PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
[    3.928000] ACPI: PCI Interrupt 0000:00:1f.1[A] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
[    3.928000] PCI: Setting latency timer of device 0000:00:1f.1 to 64
[    3.928000] ata1: PATA max UDMA/100 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x00011810 irq 14
[    3.928000] ata2: PATA max UDMA/100 cmd 0x00010170 ctl 0x00010376 bmdma 0x00011818 irq 15
[    3.928000] scsi0 : ata_piix
[    4.096000] ata1.00: ata_hpa_resize 1: sectors = 117210240, hpa_sectors = 117210240
[    4.096000] ata1.00: ATA-6: HTS541060G9AT00, MB3OA60A, max UDMA/100
[    4.096000] ata1.00: 117210240 sectors, multi 16: LBA48 
[    4.104000] ata1.00: ata_hpa_resize 1: sectors = 117210240, hpa_sectors = 117210240
[    4.104000] ata1.00: configured for UDMA/100
[    4.104000] scsi1 : ata_piix
[    4.440000] ata2.00: ATAPI, max UDMA/33
[    4.596000] usb 4-3: new high speed USB device using ehci_hcd and address 3
[    4.652000] ata2.00: configured for UDMA/33
[    4.652000] scsi 0:0:0:0: Direct-Access     ATA      HTS541060G9AT00  MB3O PQ: 0 ANSI: 5
[    4.720000] scsi 1:0:0:0: CD-ROM            TSSTcorp CDW/DVD TS-L462C GA02 PQ: 0 ANSI: 5
[    4.724000] ACPI: PCI Interrupt 0000:02:07.2[C] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
[    4.776000] ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[10]  MMIO=[e0202000-e02027ff]  Max Packet=[2048]  IR/IT contexts=[4/4]
[    4.784000] usb 4-3: configuration #1 chosen from 1 choice
[    4.796000] ACPI: PCI Interrupt 0000:02:08.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
[    4.796000] eth0: RealTek RTL8139 at 0xce916800, 00:03:25:1f:dc:7a, IRQ 10
[    4.796000] eth0:  Identified 8139 chip type 'RTL-8101'
[    4.800000] SCSI device sda: 117210240 512-byte hdwr sectors (60012 MB)
[    4.800000] sda: Write Protect is off
[    4.800000] sda: Mode Sense: 00 3a 00 00
[    4.800000] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.800000] SCSI device sda: 117210240 512-byte hdwr sectors (60012 MB)
[    4.800000] sda: Write Protect is off
[    4.800000] sda: Mode Sense: 00 3a 00 00
[    4.800000] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    4.800000]  sda:<6>8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)
[    4.824000]  sda1 sda2 < sda5 >
[    4.852000] sd 0:0:0:0: Attached scsi disk sda
[    4.856000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    4.856000] scsi 1:0:0:0: Attached scsi generic sg1 type 5
[    4.968000] usbcore: registered new interface driver libusual
[    4.972000] Initializing USB Mass Storage driver...
[    5.028000] Attempting manual resume
[    5.028000] swsusp: Resume From Partition 8:5
[    5.028000] PM: Checking swsusp image.
[    5.028000] PM: Resume from disk failed.
[    5.068000] kjournald starting.  Commit interval 5 seconds
[    5.068000] EXT3-fs: mounted filesystem with ordered data mode.
[    5.200000] sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
[    5.200000] Uniform CD-ROM driver Revision: 3.20
[    5.200000] sr 1:0:0:0: Attached scsi CD-ROM sr0
[    5.208000] usb 1-2: new full speed USB device using uhci_hcd and address 3
[    5.420000] usb 1-2: configuration #1 chosen from 1 choice
[    5.668000] usb 2-2: new low speed USB device using uhci_hcd and address 2
[    5.840000] usb 2-2: configuration #1 chosen from 1 choice
[    5.844000] scsi2 : SCSI emulation for USB Mass Storage devices
[    5.844000] usb-storage: device found at 3
[    5.844000] usb-storage: waiting for device to settle before scanning
[    5.844000] usbcore: registered new interface driver usb-storage
[    5.844000] USB Mass Storage support registered.
[    6.056000] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[0003252135021c11]
[   10.844000] usb-storage: device scan complete
[   10.844000] scsi 2:0:0:0: Direct-Access     WDC WD60 0UE-00KVT0       0000 PQ: 0 ANSI: 0
[   10.844000] SCSI device sdb: 117210240 512-byte hdwr sectors (60012 MB)
[   10.848000] sdb: Write Protect is off
[   10.848000] sdb: Mode Sense: 27 00 00 00
[   10.848000] sdb: assuming drive cache: write through
[   10.848000] SCSI device sdb: 117210240 512-byte hdwr sectors (60012 MB)
[   10.848000] sdb: Write Protect is off
[   10.848000] sdb: Mode Sense: 27 00 00 00
[   10.848000] sdb: assuming drive cache: write through
[   10.848000]  sdb: sdb1
[   11.148000] sd 2:0:0:0: Attached scsi disk sdb
[   11.148000] sd 2:0:0:0: Attached scsi generic sg2 type 0
[   18.176000] Linux agpgart interface v0.102 (c) Dave Jones
[   18.496000] intel_rng: FWH not detected
[   18.496000] agpgart: Detected an Intel 855 Chipset.
[   18.496000] agpgart: Detected 32636K stolen memory.
[   18.504000] agpgart: AGP aperture is 128M @ 0xe8000000
[   18.512000] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   18.536000] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   18.700000] iTCO_vendor_support: vendor-support=0
[   18.704000] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.01 (11-Nov-2006)
[   18.704000] iTCO_wdt: Found a ICH4-M TCO device (Version=1, TCOBASE=0x1060)
[   18.704000] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[   18.768000] input: Microsoft Xbox 360 Controller as /class/input/input2
[   19.316000] Yenta: CardBus bridge found at 0000:02:07.0 [161f:203a]
[   19.468000] Yenta: ISA IRQ mask 0x0090, PCI irq 11
[   19.468000] Socket status: 30000810
[   19.468000] Yenta: Raising subordinate bus# of parent bus (#02) from #02 to #06
[   19.468000] pcmcia: parent PCI bridge I/O window: 0x3000 - 0x3fff
[   19.468000] cs: IO port probe 0x3000-0x3fff: clean.
[   19.468000] pcmcia: parent PCI bridge Memory window: 0xe0200000 - 0xe02fffff
[   19.468000] pcmcia: parent PCI bridge Memory window: 0x20000000 - 0x27ffffff
[   19.468000] Yenta: CardBus bridge found at 0000:02:07.1 [161f:203a]
[   19.492000] ieee80211_crypt: registered algorithm 'NULL'
[   19.496000] ieee80211: 802.11 data/management/control stack, git-1.1.13
[   19.496000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
[   19.540000] bcm43xx driver
[   19.596000] Yenta: ISA IRQ mask 0x0090, PCI irq 10
[   19.596000] Socket status: 30000006
[   19.596000] Yenta: Raising subordinate bus# of parent bus (#02) from #06 to #0a
[   19.596000] pcmcia: parent PCI bridge I/O window: 0x3000 - 0x3fff
[   19.596000] cs: IO port probe 0x3000-0x3fff: clean.
[   19.596000] pcmcia: parent PCI bridge Memory window: 0xe0200000 - 0xe02fffff
[   19.596000] pcmcia: parent PCI bridge Memory window: 0x20000000 - 0x27ffffff
[   19.608000] ACPI: PCI Interrupt 0000:00:1f.5 -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
[   19.608000] PCI: Setting latency timer of device 0000:00:1f.5 to 64
[   19.692000] Synaptics Touchpad, model: 1, fw: 5.9, id: 0x23aeb3, caps: 0xa04713/0x10008
[   19.728000] input: SynPS/2 Synaptics TouchPad as /class/input/input3
[   20.104000] pccard: PCMCIA card inserted into slot 0
[   20.104000] cs: memory probe 0xe0200000-0xe02fffff: excluding 0xe0200000-0xe020ffff
[   20.104000] pcmcia: registering new device pcmcia0.0
[   20.380000] cs: IO port probe 0x100-0x3af: clean.
[   20.380000] cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
[   20.384000] cs: IO port probe 0x820-0x8ff: clean.
[   20.384000] cs: IO port probe 0xc00-0xcf7: clean.
[   20.384000] cs: IO port probe 0xa00-0xaff: clean.
[   20.388000] cs: IO port probe 0x100-0x3af: clean.
[   20.388000] cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
[   20.388000] cs: IO port probe 0x820-0x8ff: clean.
[   20.392000] cs: IO port probe 0xc00-0xcf7: clean.
[   20.392000] cs: IO port probe 0xa00-0xaff: clean.
[   20.428000] intel8x0_measure_ac97_clock: measured 55494 usecs
[   20.428000] intel8x0: clocking to 48000
[   20.428000] ACPI: PCI Interrupt 0000:02:09.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
[  198.988000] lp: driver loaded but no devices found
[  199.052000] Adding 650592k swap on /dev/disk/by-uuid/e150b96e-3ac4-49b3-85a6-1afdc74ac4fc.  Priority:-1 extents:1 across:650592k
[  199.216000] EXT3 FS on sda1, internal journal
[  200.028000] ACPI: Battery Slot [BAT0] (battery present)
[  200.072000] ibm_acpi: ec object not found
[  200.096000] No dock devices found.
[  200.148000] ACPI: Video Device [GFX0] (multi-head: yes  rom: yes  post: no)
[  200.188000] Using specific hotkey driver
[  200.268000] input: Power Button (FF) as /class/input/input4
[  200.272000] ACPI: Power Button (FF) [PWRF]
[  200.316000] input: Lid Switch as /class/input/input5
[  200.324000] ACPI: Lid Switch [LID0]
[  200.368000] input: Sleep Button (CM) as /class/input/input6
[  200.372000] ACPI: Sleep Button (CM) [SLPB]
[  200.416000] input: Power Button (CM) as /class/input/input7
[  200.420000] ACPI: Power Button (CM) [PWRB]
[  200.432000] ACPI: AC Adapter [AC] (on-line)
[  200.496000] pcc_acpi: loading...
[  205.728000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[  206.864000] [drm] Initialized drm 1.1.0 20060810
[  206.872000] ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LNKA] -> GSI 5 (level, low) -> IRQ 5
[  206.872000] [drm] Initialized i915 1.6.0 20060119 on minor 0
[  206.876000] [drm] Initialized i915 1.6.0 20060119 on minor 1
[  207.656000] ppdev: user-space parallel port driver
[  208.452000] apm: BIOS not found.
[  208.640000] Bluetooth: Core ver 2.11
[  208.640000] NET: Registered protocol family 31
[  208.640000] Bluetooth: HCI device and connection manager initialized
[  208.640000] Bluetooth: HCI socket layer initialized
[  208.684000] Bluetooth: L2CAP ver 2.8
[  208.684000] Bluetooth: L2CAP socket layer initialized
[  210.680000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[  210.732000] eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
[  212.956000] NET: Registered protocol family 17
[  214.192000] NET: Registered protocol family 10
[  214.192000] lo: Disabled Privacy Extensions
[  224.700000] eth0: no IPv6 routers present
[  235.484000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[  260.216000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[  284.992000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[  309.804000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
[  334.620000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.


then it told me to type in #cat /dev/input/js0 (which I went to that destination, and yes it does exist it is there) and type buttons, and i should see symbols if so xbox controller is working, else it isn´t working.
carl@ubuntu7:~$ #cat /dev/input/js0

Well the reason why I wrote this was because I truly read that tutorial, and did my best, but didn´t get the results I wanted. AH, I like linux I was able to fix my audio problem after really taking a look at what alsa is, and what it´s default settings are in alsamixer, and I fixed my wireless controller problem, and everything, and now I am still trying to throw the xbox360 controller on my system, so I can play games, and make games with it of course. Well, whatever help/suggestions/tip/comments I do appreciate negative or positive. I´m just trying to learn all of this right now, and I am quite new to linux, but I do already love it. oh also, Thanks in advance,

Share this post


Link to post
Share on other sites
Advertisement
Well, I have no experience with joysticks under linux, but here's an old guide on the Ubuntu forums, and here's a thread with some changes that are needed to get it to work under the latest Ubuntu. It's probably a better idea to follow that guide, since Gentoo and Ubuntu are very different.

Share this post


Link to post
Share on other sites
Quote:
Original post by Perost
Well, I have no experience with joysticks under linux, but here's an old guide on the Ubuntu forums, and here's a thread with some changes that are needed to get it to work under the latest Ubuntu. It's probably a better idea to follow that guide, since Gentoo and Ubuntu are very different.


OK, I followed the entire forum downloading the latest .c and .h files, making sure I had the right kernel which I´m not sure if I do or not, and seeing if I have the controller working by pressing the button after I type in cat /usb/input/js0

Well here is what is up!

I type in cat /usb/input/js0 in the command line then go to my controller and press buttons and weird symbols start to pop up in the terminal like crazy.

when I type in lsusb in the terminal I get the following response

Bus 004 Device 003: ID 1058:0701 Western Digital Technologies, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c510 Logitech, Inc.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 045e:028e Microsoft Corp.
Bus 001 Device 001: ID 0000:0000

Bus 001 Device 004: ID 045e:028e Microsoft Corp. <-- is this my xbox360 controller?

If I have all of this working why does it look like it is turned off, and how can I start playing games with it, and later on make games with it?

Share this post


Link to post
Share on other sites
what do you mean it looks like it's turned off? If the symbols are appearing it should be on

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!