Jump to content
  • Advertisement
Sign in to follow this  
chefgon_ign

Problem with music and XACT for XNA

This topic is 4107 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've got a couple of WAV files for music that sound perfectly fine in Media Player, but no matter what I do they sound terrible after I send them through XACT and play them in the game. I have tried both ADPCM at various levels and regular PCM. The quality varies slightly, but they all sound awful. It is very echoy, like it was recorded in a small bathroom. Is there any way to get the music in the game to sound identical to my original WAV files?

Share this post


Link to post
Share on other sites
Advertisement
Funny story. The tutorial I was following had the music starting by pressing a key. They didn't have any check to make sure the sound only starts once, so in the time it takes you to release that key the sound has started many times and is playing over itself. Thus, the echo sound.

It sounds fine now.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!