• Advertisement
Sign in to follow this  

Missing LIBC.lib in VC 8

This topic is 3957 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have been trying to compile something in VC 8 (Some random OpenGL stuff), and when I try to compile, it tells me that I'm missing a LIBC.lib. Where do I get this? And why isn't it there already? Thank you in advance...

Share this post


Link to post
Share on other sites
Advertisement
libc.lib is the single threaded static runtime library which is no longer available since VC8. Change project settings to a multi threaded runtime library instead. Project->Properties->Configuration Properties->C/C++ and select a library under Runtime Library. Multi Threaded (/MT) or the debug version would the closest match to what libc.lib is.

Share this post


Link to post
Share on other sites
Hmm.. I have now tried to get it to work.. But even though I have set it to Multi Threading it keeps looking for the libc.lib

This is how my settings are like and you can even see the errors when trying to build with the current settings.

http://img98.imageshack.us/my.php?image=msvchn9.jpg

Share this post


Link to post
Share on other sites
Maybe some third party library you use is compiled with an old version of VC and use the single threaded runtime library. Looking at the source in the background, take a look at GLFW for example. If it's compiled with the single threaded library, then it will need libc.lib. Recompile it with a multi threaded runtime library instead.

Share this post


Link to post
Share on other sites
Quote:
Original post by Brother Bob
Maybe some third party library you use is compiled with an old version of VC and use the single threaded runtime library. Looking at the source in the background, take a look at GLFW for example. If it's compiled with the single threaded library, then it will need libc.lib. Recompile it with a multi threaded runtime library instead.


That's the error... Why didn't I think of that myself :( But thanks a lot ;) Thanks to all who took their time to help me :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement