Sign in to follow this  

problem with the plane

This topic is 3813 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi all! i created a plane in 3ds and exported in x format with panda exporter all seems that works fine, but when i render in my project I look that the textures are only in the back side of the plane ( in fact the plane is not visible, but if i go down with my camera and look up I see the correct texture...) what's the problem?? is in my program or in the exporter?? thanks p.s. is my first post!! hi all!

Share this post


Link to post
Share on other sites
My guess is that the winding is reversed and that, consequently, the wrong face is being culled. DirectX assumes counterclockwise vertices by default, and the exportor (presumably) does it the other way around. Two possible solutions:
1) reverse the winding manually (or look for a switch in the exporter);
2) look at IDevice::SetRenderState( D3DRS_CULLMODE, D3DCULL_CW ); (or other options similar to this one)

Share this post


Link to post
Share on other sites
Quote:
Original post by Todo
1) reverse the winding manually (or look for a switch in the exporter);


thanks in advance!
did you know how-to do this in panda??

Share this post


Link to post
Share on other sites

This topic is 3813 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this