Jump to content
  • Advertisement
Sign in to follow this  
capn_midnight

[.net] XNGSE install borked config manager

This topic is 4021 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So, over the last couple of weeks I started noticing that VC# 2k5 EE didn't have a drop down box to select the project configuration type (debug or release). That seemed pretty odd, since I thought I remembered seeing it. It became rather annoying, as I had to open the project settings and manually change the compiler options in order to switch between a debugging and a release build configuration. Then, I reallized all my XNA game projects had the configuration drop down box, right next to the "start program" button. And the configuration manager option was back on the tools menu. To test it, I created one new project for each project template that XNAGSE had, and the only projects that had configuration management were XNA projects. Now, this is silly, because XNA games on Windows build no differently than windows applications for x86 processors. After creating the XNA game project, I can use the project settings page to completely reconfigure what type of project it is (even a console app), and still have the configuration manager. So it seems that after installing XNAGSE, only the XNA project templates get the configuration manager, for some reason. I noticed that it is a little different, now with an option to select a target platform (mine reads "X86" and "All Platforms"). I can't seem to get the configuration manager to show up on any projects that I previously created as normal projects. Anyone else see this?

Share this post


Link to post
Share on other sites
Advertisement
By default, C# Express has a bunch of options hidden. GSE's solution/project files have them turned on.

You should be able to enable this for other projects by going to Tools/Options and clicking "Show all settings." Then, in the Projects and Solutions section, make sure "Show advanced build configurations" is selected.

If that doesn't do it, try going into the toolbar configuration and make sure the solution configurations item is included.

Share this post


Link to post
Share on other sites
Before writing this post, I had been all over the Options screen, and even had the "show all settings" check box marked, but somehow I completely skimmed over the "show advanced build configuration" setting. Thanks.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!