Jump to content
  • Advertisement
Sign in to follow this  
horeaper

No effect of ID3DXPMesh??

This topic is 4160 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

1. Render 100 meshes, FPS:42 2. SetNumFaces() to 1/4 of original, Render 100 of them, FPS:42 No effect?? My PC is P4 2.4A + Radeon 9550, 1G RAM, SDK version is April 2006

Share this post


Link to post
Share on other sites
Advertisement
There are a lot of factors at play here. First, make sure that your LOD call actually succeeded and isn't failing or something. How many verts/tri's did a mesh have to begin with? It is likely that you are simply not throwing enough at your card to make an even noticable dent in performance. The low framerate could be coming from a limit in batching or the shaders.

Share this post


Link to post
Share on other sites
I watched the render result, the faces are indeed reduced. I just wondering why the fps doesn't change.
Maybe I'll try to reduce the number of beginXXX endXXX calls...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!