Sign in to follow this  

d3d10 alpha testing

This topic is 3778 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Am I supposed to use the clip() function to simulate alpha testing? I have it working with that, but I just want to make sure that is the "right" way to implement it.

Share this post


Link to post
Share on other sites
That's correct, you can use clip() or discard for alpha testing in d3d10 to work how alpha testing did in d3d9.

EDIT:
Its potentionally more efficient this way, as alpha testing early in your shader can allow you to skip the rest of a possibly large shader.

Share this post


Link to post
Share on other sites
There is no more fixed-function pipeline in DX10, so everything that used to be done automatically for you before (such as alpha testing) now needs to be done by your shaders. Check out the FixedFuncEMU sample in the SDK to get an idea of what else needs to be emulated.

Share this post


Link to post
Share on other sites

This topic is 3778 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this