Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

CoolTomK

exporting materials with BMPs in 3ds

This topic is 6221 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Whenever I try to export a model that contains a material with a bitmap texture into a Microsoft .x file (or any other format) it does not save the BMP texture info, and just shows the color of the material when I render it in my game, or any .x model viewer. But 3DS MAX does render the texture on my object.

Share this post


Link to post
Share on other sites
Advertisement
I think this is something to do with the way DirectX and the .x format handle textures. Have you posted this on the programmers forum?

Out of curiousity, have you tried the same textures but as .jpg or .tga? (well, to find out if it''s a problem with bmps)

Make sure the model ahas texture co-ordinates. (UV co-ord or texture cooridnates assigned to primative)

...
Hope this helps.


www.stephen-hawes.co.uk

Share this post


Link to post
Share on other sites
Theres nothing wrong with my code or the way I am loading files, zonbie, because I can load other .X files into my game with textured materials just fine(using MS''s .X file class). I also checked out the .X file itself and found no refernces to the bitmap texture I am loading. Im Pretty sure that it has to be a setting in 3DS MAX that I haven''t set properly. Oh yeah, Im using 3D Studio MAX r3.0

-thanks in advance

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
If you are using the DirectX SDK viewer, then the viewer will look in the Direct3D\Media Directory for the bitmaps rather than the directory the .x file is in.

Stuff everything into the Media directory.

Share this post


Link to post
Share on other sites
I just reinstalled 3ds max with the full install(I had the minumum install originally) and everything works now.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!