Archived

This topic is now archived and is closed to further replies.

DirectSound compile error!

This topic is 6080 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! I have problems with compiling my DirectSound App. I have included dsound.h and my compiler (msvc 6.0) is configurated. I have included the dsound.lib and winmm.lib in the project. I''m using DirectX 7 SDK. But it complains about the "WAVEFORMATEX" thing, I get the following errors: c:\sdk\dx7\include\dsound.h(61) : error C2143: syntax error : missing '';'' before ''*'' c:\sdk\dx7\include\dsound.h(61) : error C2501: ''LPCWAVEFORMATEX'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(128) : error C2146: syntax error : missing '';'' before identifier ''lpwfxFormat'' c:\sdk\dx7\include\dsound.h(128) : error C2501: ''LPWAVEFORMATEX'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(128) : error C2501: ''lpwfxFormat'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(142) : error C2146: syntax error : missing '';'' before identifier ''lpwfxFormat'' c:\sdk\dx7\include\dsound.h(142) : error C2501: ''LPWAVEFORMATEX'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(142) : error C2501: ''lpwfxFormat'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(193) : error C2146: syntax error : missing '';'' before identifier ''lpwfxFormat'' c:\sdk\dx7\include\dsound.h(193) : error C2501: ''LPWAVEFORMATEX'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(193) : error C2501: ''lpwfxFormat'' : missing storage-class or type specifiers c:\sdk\dx7\include\dsound.h(337) : error C2061: syntax error : identifier ''LPWAVEFORMATEX'' c:\sdk\dx7\include\dsound.h(346) : error C2061: syntax error : identifier ''LPCWAVEFORMATEX'' c:\sdk\dx7\include\dsound.h(607) : error C2061: syntax error : identifier ''LPWAVEFORMATEX'' c_sound.cpp Error executing cl.exe. Game.exe - 14 error(s), 0 warning(s) Anyone who know what''s wrong ?? Thanks in Advance ---------------------------- Nali nali@gdnmail.net www.titancoders.net ----------------------------

Share this post


Link to post
Share on other sites