Jump to content
  • Advertisement
Sign in to follow this  
Crusader2

DirectX conflict on vista?

This topic is 4095 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I want to play medieval total war 2 on my vista but it keeps saying D3DX9_30.DLL is missing. I tried to download the file but I don't know what to do with it. So I figured I would just download direct x 9.0c. however on my comp right now I have directx 10. Will downloading 9.0c screw up my comp and get rid of 10 or will they work together? Thx in advance.

Share this post


Link to post
Share on other sites
Advertisement
This is not a general DirectX support forum. Perhaps you should contact the publisher of your game and see if they have a solution.

Share this post


Link to post
Share on other sites
Quote:
So I figured I would just download direct x 9.0c. however on my comp right now I have directx 10.

Actually, it has directx 9.0c. This is a problem with the game I'm thinking.

Share this post


Link to post
Share on other sites
It technically has a version of directx 9.0, but it is missing several things for some reason (notably D3DX9_30.DLL). Would it be alright for me to download the directx 9.0c off the net?

Share this post


Link to post
Share on other sites
I just did a quick google search and yes, it seems people have fixed the problem by (re?)installing directx9. They also said that if it says you already have an up-to-date version than get a redistributal copy and upgrade that way.
Hope that works for ya.

Share this post


Link to post
Share on other sites
Quote:
Original post by Dave Hunt
This is not a general DirectX support forum. Perhaps you should contact the publisher of your game and see if they have a solution.


D3DX is an optional part of the DirectX suite of technologies, if you're using an application that depends on it then that application should have installed it. If it doesn't, it's a badly deployed application - simple as that [smile]

You cannot install DX9c on Vista. Currently there are *no* versions of DX you can install on it as it ships with the latest-n-greatest already. However, some DX redist packages like the web installer may install optional libraries and skip the core components.

Any further questions and you can follow Dave Hunt's advice [wink]

Jack

Share this post


Link to post
Share on other sites

This topic is 4095 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!