Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

penetrator

speed improvements: check this ...

This topic is 6291 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i hope this can help other newbies like me: building the terrain engine for my flight simulation, i noticed fps where dropping from 100 to 50 when, moving the camera, i was looking at where land and water intersected each other (land and water are two separate triangle strips). I tought that was the reason of the fps drop, i.e. the depth buffer calculations or perhaps the z-buffer fighting. But just casually i reduced the water texture from 128x128 to 64x64 and wow ... now i get 100 fps everywhere !!! glHorizon_Project

www.web-discovery.net

Share this post


Link to post
Share on other sites
Advertisement
this is normal behaviour. and part of the reason that you use mipmapping. smaller textures equals greater speed

http://members.xoom.com/myBollux

Share this post


Link to post
Share on other sites
The sudden 50fps speed drop also sounds suspicously like vsync is enabled. Try disabling it and the fps drop wouldnt be nearly as big.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!