Sign in to follow this  

Usage of depth/stencil-buffers messes up the screen

This topic is 3731 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi everybody! I've encountered a problem while implementing a few things with Managed DirectX and C#. Basically I'm satasfied with the API and my results, but now I try to make my (atm windowed) application fullscreen. But before that, i wanted to use the depth and stencil buffers for rendering, so I enabled them using the PresentationParameters. I chose DepthFormat.D24S8 to fit my needs. But then I've encountered the problem: The texture rendered completly perfect, when the stencil/depth buffers are disabled, is messed up when i use the buffers. Googling and working on this problem for some hours did not help me at all, so I post you the setup of the Direct3D device: [url]http://rafb.net/p/uFgJWa73.html[/url] And the two pictures (left without the buffers, right with them): [img]http://www.scienceandcode.org/withoutdepth.png[/img] [img]http://www.scienceandcode.org/withdepth.png[/img] I hope some of you guys have a clue what this error is all about, because my resources are definetly exhausted

Share this post


Link to post
Share on other sites

This topic is 3731 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this