Jump to content
  • Advertisement
Sign in to follow this  
pollux070282

Usage of depth/stencil-buffers messes up the screen

This topic is 3946 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi everybody! I've encountered a problem while implementing a few things with Managed DirectX and C#. Basically I'm satasfied with the API and my results, but now I try to make my (atm windowed) application fullscreen. But before that, i wanted to use the depth and stencil buffers for rendering, so I enabled them using the PresentationParameters. I chose DepthFormat.D24S8 to fit my needs. But then I've encountered the problem: The texture rendered completly perfect, when the stencil/depth buffers are disabled, is messed up when i use the buffers. Googling and working on this problem for some hours did not help me at all, so I post you the setup of the Direct3D device: http://rafb.net/p/uFgJWa73.html And the two pictures (left without the buffers, right with them): withoutdepth.png withdepth.png I hope some of you guys have a clue what this error is all about, because my resources are definetly exhausted

Share this post


Link to post
Share on other sites
Advertisement
Well, umm.... AAAAAAAAAAARGH! Or more polite: You're right -.- Stupid mistake. Need sleep ^^ Thanks a lot, clearing all buffers explicitly fixed the problem.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!