Sign in to follow this  

D3D Drawing / Strange result

This topic is 3727 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

http://home.no.net/gmg/result.jpg Is there anything in the drawing commands that could cause such a result, anything besides an error in the vertex/index buffer? Basicly have two projects (sample+own), both have identical vertex and index buffers, one works, the other doesnt. (everything is connected to the start, and it stops rendering the 'terrain' all of the sudden, supposedly 64x64) -- Also what is the recommended/absolute maximum vertices in a vertex buffer? Note: also posted in beginners, but figure it may be easier to get a reply here.

Share this post


Link to post
Share on other sites
Are you using 32bit indexbuffers? Then you should check whether your video-hardware supports them... i had weird problems with that too.
Infact, it's good practice to check for all capabilities used in your code, @ initialization.

Do you have installed the DX Debug runtimes? They might give you some info about things that go wrong.

good luck.. hope you can kill the bug ;)

Share this post


Link to post
Share on other sites
Debug info was actually turned off by a mistake, on now but no errors are detected.

The index buffers are 16 bits


Thing is in the sample code(from a book), it displays fine.
I've dumped the index and vertex buffers from both my code and the sample code, the data is identical.

Share this post


Link to post
Share on other sites
Supposed to be a 64 x 64 grid, instead it stops halfway and links everything to the beginning.

It does however work fine under 32 bit, just gave up on googling the differences between a 16 and 32 bit index buffer, too many random results.

Looking into it at some later date, sample code still runs fine on 16bit :/

Share this post


Link to post
Share on other sites

This topic is 3727 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this