Jump to content
  • Advertisement
Sign in to follow this  
fgutierrez

Anti-aliasing

This topic is 3936 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi! I´m trying to get anti-aliasing in my polygons using blending function. The operations sequence I carry out is the next: /* With GL_POLYGON_SMOOTH OGL calculate coverage values for vertex in the edges of polygons.This coverage values multiplies alpha values for each fragment so that it blends smoothly with the incoming polygons */ glDisable(GL_DEPTH_TEST); glDisable(GL_FOG); glEnable(GL_BLEND); glEnable(GL_POLYGON_SMOOTH); glBlendFunc(GL_SRC_ALPHA_SATURATE,GL_ONE); /* Here I place my rendering primitives */ .... .... .... /* I enable the deepth buffer */ glEnable(GL_DEPTH_TEST); glEnable(GL_FOG); glDisable(GL_BLEND); glDisable(GL_POLYGON_SMOOTH); I get surprised when I execute this code and the scene seems to be black.I tried to execute this code in other computer and the behaviour was different so that my geometric figures appears white. I don´t inderstand the reason of this behaviour, could Someone help me? Thank you.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!