Sign in to follow this  
andrew1123

[web] CSS problem

Recommended Posts

http://nonsensep.awardspace.com/ Why doesn't this work??? All three boxes in my code have table.text. I set the left and right borders to solid 16px blue, and it worked for two of the boxes, but not the one with 'Home - Website under construction' (There should be blue to the left and right of the white box). It worked when I put the table.text CSS in the actual HTML (style=".."), but I wanted to clean it up and put it in a stylesheet, and it doesn't work now. I get the same problem with Firefox, IE, and Opera. Can someone please look at the source code and find out what's wrong? And if you don't see any problem, please use PrtSc and post the screenshot. Here's what it looks like for me: http://img235.imageshack.us/img235/6682/scrbq2.jpg

Share this post


Link to post
Share on other sites
element.style overrides table.text and sets the borders to width 0.

I highly suggest you install the "FireBug" extension for firefox. It took me all of three seconds to find the problem using FireBug. I simply clicked "inspect", clicked on the box and looked at the styles. FireBug will tell you all the styles that apply to an element and tell you which style overrides what other style.

Share this post


Link to post
Share on other sites
But it works fine for the other two table.text's who use element.style's. But I'll look into getting Firebug.

Nevermind. For some reason, it just looked like the other two were working. I'll just change border-width: 0px to border-top-width: 0px; border-bottom-width: 0px;

Thanks.


I know why the other two tables seemed to have the two borders. It's because I put padding on the table cell.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this