Jump to content
  • Advertisement
Sign in to follow this  
Maverick Programmer

Visual Studio Express

This topic is 4058 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
Just do a search on these forums for VS 6.0 criticism. But basically:

Unsupported by Microsoft

About 10 years old (released around the same time as Win98)

Supports standard C++ incorrectly (won't work with most other compilers, especially with more advanced code)

Is known to emit broken machine code (from what I've heard)

Share this post


Link to post
Share on other sites
yeah, sorry no MFC (or ATL or resource editor) in the express version... I think the "standard" is 240$ or so...

Share this post


Link to post
Share on other sites
You do not have to use language extensions or windows specific libraries with Visual C++ Express Edition. It depends on the library you use on whether your game will be cross-platform.

Share this post


Link to post
Share on other sites
Quote:
Original post by PCN
MFC? Also, I'm righting a game on Windows, but it should be cross-platform.

Then you shouldn't be touching MFC or ATL unless you want to write separate codepaths. It's lack of inclusion in VS2005 Express shouldn't be a problem, then.

Share this post


Link to post
Share on other sites
I loved Express, and I bought Standard several month later only because I wanted a resource editor and Visual AssistX.

My only dissapointment is that they include a profiler only with the uber-expensive version :(

Share this post


Link to post
Share on other sites
Quote:
Original post by PCN
What's the difference. Is the coding style different? Thanks.


VS Express is a C++ compiler; VS 6.0 is not, according to the current definition of the language. So the code will differ, yes; the language compiled by VS 6.0 is lost (or should be >_<) in the sands of time. Coding *style* is something that's up to the individual and doesn't really even depend much on what language you're using.

Share this post


Link to post
Share on other sites
So I'm behind apparently. :D
Thanks. Also, does that mean I'm going to need to get new library files and what-not? I mean- should I delete EVERYTHING that VC 6.0 used or just move 6.0 stuff and replace with Express?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!