Jump to content
  • Advertisement
Sign in to follow this  
wforl

OpenGL problems with alpha in planes

This topic is 3897 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, ive just started this project, and as you can see im having trouble with the alpha on my images, on the left of the trees its ok, but on the right it does some weird blocking thing. Ive enclosed the project if any of you wouldn't mind looking at it, at the moment its very rough code, and needs to be cleaned up and worked on, but i dont know why this is happening. the folder is only 3mb, thanks Photo Sharing and Video Hosting at Photobucket OpenGL Coursework.zip

Share this post


Link to post
Share on other sites
Advertisement
each pixel in the depth buffer can only store one value (usually the closest)

thus u need to either not write into the depthbuffer
eg glDepthMask(GL_FALSE);
or better yet prolly in this case
enable alphatest with GL_GREATER 0.0

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!