Sign in to follow this  
suliman

settings in VC++2005 (edit and continue problem)

Recommended Posts

Hi I got problems with edit and continue. A user gave me this comment but i cannot message him. So my question is, where exactely do i apply these settings and do i put them all in a line like so: /ZI /Od The comment was: It sounds like your project settings are messed up - make sure that all of the standard debug options are set in the project settings; ( /ZI (debug info for edit & continue), /Od (disabled optimisation), /RTC1 (basic runtime checks), /MTd or /MTDd (debug runtime library)...

Share this post


Link to post
Share on other sites
Hello,

There are two places you can put that in.

Under Project Properties->C/C++->Command Line, just add the options to the Additional Options text box.

Or, you can change the appropriate IDE options:

Under Project Properties->C/C++->General, change Debug Information Format to Program Database for Edit & Continue (/ZI). This enables /ZI option.

Under Project Properties->C/C++->Optimization, change Optimization to Disabled (/Od) This invokes the /Od option.

Share this post


Link to post
Share on other sites
tried both and/or combinations and still edit and continue in greyed out in the debug menu.

Is this a known issue or can there be other settings that disables edit and continue? It is enabled in options and i run debug with the mentioned commands both on and off, still its not available.

I try to edit and continue different files, like my main.cpp or some other cpp. But no...

I really need this feature.
Erik

Share this post


Link to post
Share on other sites
Hello,

Quote:

can there be other settings that disables edit and continue?

Are you trying to disable it? The /ZI option that you wanted to set enables it...

If you can describe the initil problem in more detail, we might be able to help you out more.

Share this post


Link to post
Share on other sites
No i want to use edit and continue but now i cannot.

I have all the stuff set as it should be, yet edit and continue is greyed out in the menu. I run debug mode, i have edit and continue enabled in options, and i try both with and without different commands like these discussed in this tread. Still no luck...

E

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this