Jump to content
  • Advertisement
Sign in to follow this  
MuchoPichu

DX runtime break point "issue"...

This topic is 3882 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I've been using the DX runtime to debug some memory leak issues, I know, I know, really fun and you wish you were cool like me. Well! Good news is that I used the Control Panel debugger to set a break point on an AllocID... and it works. It breaks on the Alloc as commanded. Bad news is that I can't get it to stop breaking on the AllocID. I unchecked this in control panel, I cleaned the solution, I even copied the directory, and deleted almost everything but the source files and rebuilt the whole enchilada... and the thing still breaks on the breakpoint. Nice but I need to run the thing to debug it some more and ... no luck. Uh, anybody know how I can get it to STOP breaking? Thanks - Mucho.

Share this post


Link to post
Share on other sites
Advertisement

Well I'll be a monkey's pickle... That sure did it. Admiral, I can't really explain it, but somehow I just feel "safe" knowing that you're out there. :)

Btw, favorite understated quote from the D3D debug docs -

"Debugging a Direct3D application can be challenging."

Hmmm - Mucho.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!