Jump to content
  • Advertisement
Sign in to follow this  
HeroOfSpielburg

[MDX] Can't pass Direct3DCreate9 with Debug version of D3D9

This topic is 4003 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, A while ago I made a post about trouble I was having using the Debug Version of D3D9. Essentially if I enabled it through the D3D control panel, any call to Direct3DCreate9 would fail (even the ones in the SDK samples). I fought with it for months, but never could figure out why. http://www.gamedev.net/community/forums/topic.asp?topic_id=454956&forum_id=10&gforum_id=0 Anyway, the post is retired now, but in case anyone else has this same mind-boggling behavior, I finally have it working on my PC. All it took was a complete reinstall of VisualStudio and all of my SDKs (DirectX, .NET Framework, etc.). I wish there was a better way, but if you're out of luck and really need the Debug version of D3D, this is a way to go apparently. Best,

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!