Jump to content
  • Advertisement
Sign in to follow this  
Boder

Ubuntu - Gutsy Upgrade, Display Problems

This topic is 3849 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a BenQ FP767 LCD with 1280x1024 native resolution and an Nvidia 6600GT w/ 128 mb. I didn't expect anything to go wrong from Feisty to Gutsy. After the upgrade, the screen was set on 320x240 or 640x480 zoomed in on the upper 1/8 of the actual desktop, so I couldn't access the window to change the display resolution. I ran
sudo dpkg-reconfigure xserver-xorg

and restarted. Everything appears to go fine until it's just about to put up the init menu, then it flashes to the console and goes black again then it goes to "Ubuntu is running in low graphics mode." From there if I push continue, same thing happens (black->console->black->console). If I configure the drivers for both, same story. But if I use the VESA driver, then I see a woven black/white pattern with the confirm dialog partially showing in the upper left corner. However attempting to start with this configuration yields the same black flashes. Again I ran
sudo dpkg-reconfigure xserver-xorg

and everything was correct. Before I had been using the NVIDIA proprietary driver and had started out using Feisty with a CRT, then I had dual monitor with the CRT and LCD, and finally I was just using the LCD before I upgraded. I wonder if this information might help. Thank you.

Share this post


Link to post
Share on other sites
Advertisement
Try taking a look at /var/log/Xorg.0.log after starting X. The lines that begin with (EE) are errors. If you can't figure out what's wrong, let us give it a shot. If you'd like, also post the /etc/X11/xorg.conf file that you're using.

Share this post


Link to post
Share on other sites
I think you're meeting Ubuntu's bulletproof X.org. The latest version of Ubuntu falls back to low-graphics mode (some sort of "safe" mode) when it cannot start X. Instead of doing dpkg-reconfigure, try editing your /etc/X11/xorg.conf file directly. What driver does it use? 2D nv? or the binary nvidia blob?

Does the Live CD work? Or does that fall back to low graphics mode as well?

Share this post


Link to post
Share on other sites
Super thanks to both of you.

It worked great before the upgrade. I haven't tried the CD. And if worst comes to worst, I can do a clean install of Feisty.

Note, the "device" section fails for VESA, nv, and nvidia.

xorg.conf
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Failsafe Device"
Boardname "NVIDIA GeForce 6 Series"
Busid "PCI:1:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
EndSection

Section "Monitor"
Identifier "Failsafe Monitor"
Vendorname "BenQ"
Modelname "BenQ FP767"
Horizsync 31.5-83.0
Vertrefresh 56.0-76.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Failsafe Device"
Monitor "Failsafe Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1792 1344
Modes "1024x768@60" "1152x864@75" "1024x768@70" "1280x1024@75" "1024x768@75" "1280x960@60" "832x624@75" "1280x1024@60" "800x600@60" "1280x960@75" "800x600@75" "1400x1050@60" "800x600@72" "1400x1050@75" "800x600@56" "1600x1200@65" "640x480@75" "1600x1200@60" "640x480@72" "1792x1344@60" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce 6 Series"
Busid "PCI:1:0:0"
Driver "nv"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "640x480@60" "640x480@72" "640x480@75" "800x600@56" "800x600@72" "800x600@75" "800x600@60" "832x624@75" "1024x768@75" "1024x768@70" "1024x768@60" "1152x864@75" "1280x1024@75" "1280x960@60" "1280x1024@60" "1280x960@75" "1400x1050@60" "1400x1050@75" "1600x1200@65" "1600x1200@60" "1792x1344@60"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor1"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection


Wow, the Xorg log is beefy. Here is Xorg.9.log because Xorg.0.log didn't show errors.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/lib/xorg/modules//libint10.so
(II) VESA(0): initializing int10
(WW) VESA(0): Bad V_BIOS checksum
(II) VESA(0): Primary V_BIOS segment is: 0xc000
(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 131072 kB
(II) VESA(0): VESA VBE OEM: NVIDIA
(II) VESA(0): VESA VBE OEM Software Rev: 5.67
(II) VESA(0): VESA VBE OEM Vendor: NVIDIA Corporation
(II) VESA(0): VESA VBE OEM Product: nv43 Board - p216h0
(II) VESA(0): VESA VBE OEM Product Rev: Chip Rev
(==) VESA(0): Write-combining range (0xc0000000,0x8000000)
(II) VESA(0): virtual address = 0xaf0c2000,
physical address = 0xc0000000, size = 134217728
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Backing store disabled
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Generic Keyboard: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(**) Configured Mouse: Sensitivity: 1
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) Configured Mouse: ps2EnableDataReporting: succeeded
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.


I have a feeling it just might be irrepairable from some quirky thing that happened during the upgrade.

Share this post


Link to post
Share on other sites
From the error, it looks like it can't start the GLX driver. IIRC that one needs the binary "nvidia" driver, while your device section says it uses the 2D "nv" driver. Either turn off GLX extension (don't know how by heart. sorry) or install the binary nvidia driver.

Share this post


Link to post
Share on other sites
Yeah baby! Wooo WOOOO. WOOO WOOO. Hell yes, it's working.

Unfortunately I won't be able to explain. I did what I've done before, stupidly (the definition of insanity is repeating the same thing and expecting different results). However different results, YIELD it did.

Only thing I did differently was CTRL+ALT+BKSPC and startx instead of restarting after reconfiguring the xserver.

thanks again

Share this post


Link to post
Share on other sites
Piss balls! I spoke too soon.

It's back to only showing an 1/8 of the screen. It starts out fine with the orange background, then right before it turns on NUM LOCK it gets screwy. The mouse is constrained also (meaning it doesn't go off the screen even though there is more desktop).

If anyone knows how to

a) change display resolution from the console
b) kill the xserver on tty7 (or tty9?) and get to the console

Share this post


Link to post
Share on other sites
Quote:
Original post by Boder
a) change display resolution from the console

To change actual resolution: xrandr --size width/height. To change viewport size, use Control+Alt+Keypad Plus/Minus.
Quote:
Original post by Boder
b) kill the xserver on tty7 (or tty9?) and get to the console

Hit Control+Alt+F1 to switch to a terminal. Login and kill your desktop manager (for gdm: sudo /etc/init.d/gdm stop) to kill X. To start X again, use start instead of stop.

Share this post


Link to post
Share on other sites
It's pretty messed up.

The greeter application is crashing now. The worst part about it is that it works perfectly after I reconfigure the xserver and "startx" on tty5.

It's messing up the monitor and I think it has to do with me using another monitor before.

NOTE: this latest upgrade uses XGL by default and when I go to "NVIDIA settings" it tells me that it's not using the nvidia driver. BUT it IS. GLxgears goes at 3000+ fps. But GLXinfo says no direct rendering.

As soon as I tell it I have a BenQ FP767 and switch the resolution. It reverts to a "Custom" monitor and only allows the mode I chose. However it is using a 1733x1428 (or something close) desktop and focuses on the upper-right 1024x768. It's NOT the viewport, because CTRL+ALT+ +/- doesn't work and I can't scroll (I saw how this worked when it was working on tty5).

I tried disabling XGL and disabled Auto-Login so now I can't even get past the crashing greeter application.

Using gdm start/stop doesn't seem to kill the xserver or even the window manager on tty7. Can I kill the xserver without restarting it (i.e. CTRL+ALT+BKSPC).

FUBAR FUBAR FUBAR FUBAR FUBAR FOOOBARRR F*CKED UP BEYOND ALL REPAIR

Share this post


Link to post
Share on other sites
Your xorg.conf file is considerably different from what Ubuntu Gutsy generated for me. I've never run into Bulletproof-X when I wasn't trying to, but I do remember it generated a strange configuration file much like yours (although it places mine in xorg.conf.failsafe). Your virtual resolution is being set to that odd number inside your xorg.conf, though I couldn't say why.

Have you used the binary NVidia drivers yet? If you're willing to try them, we can continue by trying out my xorg.conf with modified values. I'll go through this overly manually just to make sure it works. It's not really the Ubuntu way, but apparently something is not quite right as it is.

Drop to a terminal. I'm not sure why or how GDM is mad at you, but just in-case, let's reconfigure it to defaults (either with dpkg-reconfigure or by removing it with --purge and then reinstalling). Next, install linux-restricted-modules and nvidia-glx with apt. Ensure that you're in the video group (groups will report what groups you belong to; adduser username video if you're not). Now, load the nvidia module (modprobe nvidia).

Instead of using any of the automagical configuration systems, try this xorg.conf out (hopefully with no typos on my part):

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
# If any of these cause errors, remove them. They're what Ubuntu
# generated for me.
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "BenQ FP767"

# Disable this if necessary, my monitor uses it.
Option "DPMS"

# Enable your Horizsync/Vertrefresh here if necessary, you can likely
# ignore the rest. I've never needed more than DPMS and Gamma.
#Horizsync 31.5-83.0
#Vertrefresh 56.0-76.0
EndSection

Section "Device"
Identifier "NVidia 6600GT"
Driver "nvidia"

# Shouldn't be necessary, but just in-case.
Busid "PCI:1:0:0"

# Disable this if necessary, I use it.
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVidia 6600GT"
Monitor "BenQ FP767"
DefaultDepth 24

SubSection "Display"
Depth 24
Modes "1280x1024" # Just the native resolution for now.
EndSubSection
EndSection


If that works, back it up. Make sure Ubuntu knows you're using the NVidia drivers (in GNOME, System -> Administration -> Restricted Drivers Manager: the "NVidia accelerated graphics driver" should show "In use") and then I'd recommend trying to have Ubuntu generate you a proper xorg.conf again, because mine is rather bare-bones.

If not, please post your error logs again. Nothing is irreparable, just sometimes hard to fix over the Internet :p.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!