Sign in to follow this  
Chris Oden

VC++ cannot open third include file but opens the two before

Recommended Posts

The includes are #include <windows.h> #include <gl\gl.h> #include <gl\glu.h> #include <gl\glaux.h> When I try to compile it doesn't complain until it comes to glaux.h. All three Open GL libraries are in the same folder and the name is correct. (it's not just the includes, the rest of the program is there too of course ) In an attempt with SDL it wouldn't find the .h files at all until I gave it the full directory like #include "C:\Program\Microsoft Visual Studio\VC98\include\SDL\SDL.h" Then it complained about not being able to open SDL.lib which I installed exactly according to lazyfoo's tutorial. I've just started checking out Visual C++, used DevC++ until now and it's more complicated than I thought but this shouldn't be a problem? It's Visual C++ 2008 Express Edition

Share this post


Link to post
Share on other sites
found this with search:
http://www.gamedev.net/community/forums/topic.asp?topic_id=476345

That solves the glaux issue...

As for the sdl one, it looks like you just typed out that #include instead of copy/paste but just double check that you put the includes in the correct directory instead of some left-over old install of VS... i use the full/retail version instead of the express editions but my default install include path was c:\program files\microsoft visual studio 9.0\vc\include
instead of vc98...

Share this post


Link to post
Share on other sites
I've just checked the GL directory included in the 6.0A version of the Windows SDK and glaux.h isn't there at all. IIRC, GLAux is very old and deprecated and obsoleted and generally it's recommended that you don't use it anymore.

I would recommend against mixing the SDL headers in with the MSVC headers because you'll end up losing track of who's responsible for which parts in there, different projects might have different versions of headers with the same names and so on. Keep them separate and add the 'include' directory inside the SDL install to the 'Additional Include Paths' option in your project, similarly for the library.

Share this post


Link to post
Share on other sites
Figures, the files shouldn't go under "Program\Microsoft Visual Studio\" at all, they go under "Program\VC\". (barely noticed the folder)

Also, because I'm afraid that ninjas will come assassinate me, I' wont use glaux.

Thanks for making me happy :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this