Sign in to follow this  

[d3d10] disabling backbuffer writes

This topic is 3634 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I want to build a depth map in a separate rendering pass. During this pass, I only need depth info, so no need to render to the back buffer. How can I disable rendering to the back buffer so that the hardware will actually skip it? Is setting a NULL pixel shader enough?

Share this post


Link to post
Share on other sites
If you want only write to a depth buffer you should only set this depth buffer during your OMSetRenderTragets call. Another way is set the RenderTargetWriteMask element of the D3D10_BLEND_DESC to 0.

Setting the pixel shader to NULL should not solve the problem as it is normally the sign that you are not interested at the pixels at all.

Share this post


Link to post
Share on other sites

This topic is 3634 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this