Jump to content
  • Advertisement
Sign in to follow this  
sprinter_trueno

CTransInPlaceFilter cannot connect

This topic is 3906 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, for one week now I try to make use of a TransInPlaceFilter to monitor PCM stream of an audio file and visualize the waveform. To do so I searched through the documentation of DS and found the recommondation to use a TIP Filter. Well, I override what is necessary, connect and doesn't work. I always get 0x80040266, transports do not match. I got bored with trying to attach the TIP to the output of the codec so I tried to connect to the async file reader filter with the same result. Connecting to the renderer also failed. Btw, I always use directconnect since I do not want any unexpected filters to be used. Here and there I found some little hints that the basics to do are unfortunately not enough and that drives me crazy. I basically read the documentation on creation of filters and all around that now for the third time and cannot believe that it is necessary to understand every bit of this twisted framework to make this simple thing work. All I need is a filter that connects to everything on both sides and just routes mediasamples through which I only want to read and not modify. Does anybody have the solution that microsoft was and is not able to provide ?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!