Jump to content
  • Advertisement
Sign in to follow this  
essial

Problems distributing VC08 C++ app

This topic is 3795 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I get a "this application configuration is incorrect" whenver I try to run a release (or debug) build of a pure win32 C++ (no .net) app on a computer that does not have visual studio installed. I even get this error when I install the VC09 C++ redistributables on said computer. I've google searched all about it, it seems to be a common problem, but have yet to figure out how to fix it. I tried setting the runtime to be "multithreaded" instead of "multithreaded dll", but that produces redfinition errors. When I tell VS to ignore libcmt.lib, it gives a single "__HUGE is not defined" error. Any ideas?

Share this post


Link to post
Share on other sites
Advertisement
Lets try to get it working with "Multithreaded DLL". Which version of Visual Studio are you using? How did you install the redistributables on the target machine?

Share this post


Link to post
Share on other sites
Thanks Ezbez, that forum post worked. I copied the files from the "Microsoft Visual Studio 9.0\VC\redist\x86\Microsoft.VC90.CRT" folder over to the application folder and everything works great!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!