• Advertisement
Sign in to follow this  

DARK GDK

This topic is 3665 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

ok, so i downloaded dark gdk, and i am using directx 10, but when i tried to run something just as a test, i got this message; 1>------ Build started: Project: Dark GDK - 2D Game4, Configuration: Debug Win32 ------ 1>Compiling... 1>Main.cpp 1>ok not tellling the directory\the game creators\dark gdk\include\darksdkcamera.h(16) : fatal error C1083: Cannot open include file: 'd3dx9.h': No such file or directory 1>Build log was saved at "file://not saying\my name here...\Documents\Visual Studio 2008\Projects\Dark GDK - 2D Game4\Dark GDK - 2D Game4\Debug\BuildLog.htm" 1>Dark GDK - 2D Game4 - 1 error(s), 0 warning(s) ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ========== can someone please tell me whats going on!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites
Advertisement
ok i solved that issue by myself, but now i have a whole new issue;


1>------ Rebuild All started: Project: plz work, Configuration: Debug Win32 ------
1>Deleting intermediate and output files for project 'plz work', configuration 'Debug|Win32'
1>Compiling...
1>Main.cpp
1>Linking...
1>LINK : fatal error LNK1104: cannot open file 'd3dx9.lib'
1>Build log was saved at "file://not saying directory\Documents\Visual Studio 2008\Projects\plz work\plz work\Debug\BuildLog.htm"
1>plz work - 1 error(s), 0 warning(s)
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

someone plz help me!!!!

Share this post


Link to post
Share on other sites
I believe it doesn't work because your "!" key is broken.

If that doesn't help, make sure that Visual Studio knows where to find the DirectX libraries. Either add the directory in the global options or in your project options. You'll most likely have to add the include directories, too, and it's a good idea to move both directories to the beginning of the list so that VC searches there first and does not confuse them with its own, old DX version.

~matt();

Share this post


Link to post
Share on other sites
Dark GDK uses DirectX 9 not DX10 which is why your having problems.

your need the August 2007 DirectX SDK.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement