Sign in to follow this  

ATI FBO y-orientation changed??

This topic is 3598 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello! I have implemented perspective shadow mapping by rendering to a depth-texture via FBO. After updating to the latest ATI driver (8.1) from my previous one (7.9 I think), the depth image appears to be flipped upside down. If I invert the y-texture coordinate, or downgrade the driver, I get correct results again. Can anybody confirm this issue? From what I know, it appears to me that the y-orientation of the rendered FBO image has changed after the driver update. If this is the case, it would be neccessary to test the orientation at program startup, but before implementing this I would like to know if this really is the problem. BTW, I use OpenSceneGraph for rendering and FBO handling, if this provides any clue. regards chris

Share this post


Link to post
Share on other sites

This topic is 3598 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this