Jump to content
  • Advertisement
Sign in to follow this  
akira32

How do I set promt format

This topic is 3791 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I use the cygwin's bash. My default prompt is $. How do I change the prompt as current directory with my user name? default $ I want $/home/user:myname:

Share this post


Link to post
Share on other sites
Advertisement
You need to set the environment variable PS1 to "$\w:\u: ". You can do this temporarily by writing "export PS1='$\w:\u: '" in the shell and hitting return. Cygwin should have a bash.bashrc file somewhere or a user local ~/.bashrc where you can replace the PS1 setting more permanently.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!