Sign in to follow this  

Keep Windows from stealing palette

This topic is 3578 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, The code I'm working with goes to full screen in 8bit using DirectDraw 2. Works great, except that if anything occurs in the background in the operating system, Windows will garbage up the palette with its own colors until I Alt-Tab out and back in. Is there some way to prevent this from occuring? If you need to see code, you can look here: http://doomlegacy.cvs.sourceforge.net/doomlegacy/doomlegacy/win32/ fabdxlib.c and win_vid.c contain stuff for setting the screen mode / palette. Any help is much appreciated! Thanks!

Share this post


Link to post
Share on other sites
Can't help you with this problem, but I'd really suggest you step away from DirectDraw 2 and move to something a little more up to date. There are a lot of Doom ports, and I'd suggest that you pick up one that's newer and perhaps uses SDL, such as PrBoom.

Share this post


Link to post
Share on other sites

This topic is 3578 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this