Jump to content
  • Advertisement
Sign in to follow this  
gamelife

vs2005 lib runtime problem

This topic is 3736 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm using VS2005 to link my own program with a 3rd party provided static lib. Both were built with multithread debug DLL. The linking step works, producing an exe, but when i run it an error pops up: "The applciation has failed to start because the application configuration is incorrect". I investigated the problem a bit and found that when i didn't link with the lib, the embed.manifest file contains the line: "Microsoft.VC80.DebugCRT" version="8.0.50608.0". When i link with the lib, the embed.manifest file contains one more line: version="8.0.50727.762". I guess the exe failed to run as the 3rd party lib is linked with a different version of msvcr80.dll which my system doesn't have. Is it possible to set my program and the lib to use the same runtime libraries? Thanks for help.

Share this post


Link to post
Share on other sites
Advertisement
You need to update your VS8 to SP1. Or you can recompile that library with your compiler if you have the source.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!