Jump to content
  • Advertisement
Sign in to follow this  
Thomas Bartholemew

basic dev-C++ question. Am I doing something wrong?

This topic is 3935 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, newcomer with a problem regarding my compiler. I use Dev-C++ (4.9.9.2) and Windows XP, and basically I'm having compiling issues. It seems that I can compile my game, then delete whole bits of code, but then when I compile it again with that code missing, the code is still there in the game! Do I need to change a setting? Or am I just being a complete amature and missing something. Any pointers would be great, t.

Share this post


Link to post
Share on other sites
Advertisement
Are you sure you are saving the changes?
Are you sure that you are deleting code in the same project as the one you compile?

Share this post


Link to post
Share on other sites
it sounds like the bits of code you delete are not processed in your compile. This can happen if your file isn't part of a project.

another reason can be around your file there is a:

#if 0
// your code here
#endif

and all code you delete never gets compiled anyways

there are lots of reasons why this can happen. To solve your problem it would probably be wise to show us an example.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!