Sign in to follow this  
all_names_taken

OpenGL OpenGL does not allow attributes of type ivec4

Recommended Posts

(1) : warning C7507: OpenGL does not allow attributes of type ivec4 I get this warning from one of my shaders, but it doesn't give an error... Do I need to bother? The things is, I've loaded bone indices into an attribute buffer with 4 GLint values per vertex. If I can't have an ivec4 attribute in the shader, do I have to change the representation in my attribute buffer as well, or is it enough to make some change in the shader? If no, what data format should I have for the indices? A 4-floats vector?

Share this post


Link to post
Share on other sites
I don't exactly now if its #version 120 or #extension GL_EXT_gpu_shader4 : enable you need to add to your shader. But this will take care of your warning.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this