• Advertisement
Sign in to follow this  

Bad quality on another computer

This topic is 3581 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello mates, I am not 100% sure how to describe the following problem, please look at these screenshots: http://perfectprefabs.com/Other/Private/laptop%20sun2.png http://perfectprefabs.com/Other/Private/desktop%20sun2.png The first is on my laptop, and the second on my desktop computer. The image is a good quality PNG and the apps are 100% the same. Also, as you can see, the planet lost quality in the RGB fields. My laptop and desktop both run the same Windows, and both run with 32bit colordepth. What might I have done wrong? Thanks, Antoon/X

Share this post


Link to post
Share on other sites
Advertisement
make sure youre getting a 32bit window + texturemaps

whilst u might ask for a 32bit color window, u dont necessary get one, so query the actual values

Share this post


Link to post
Share on other sites
Also, make sure you ask for RGB8/RGBA8 as the texture internal format, if you only specify RGB/RGBA, the driver is free to use a 16-bits internal format and you'll get banding in colors.

Y.

Share this post


Link to post
Share on other sites
I looked around a bit, and I don't seem to be able to find out how to use this RGBA8.

I tried changing PFD_TYPE_RGBA.. but that doesn't seem to be what you guys are talking about..

Where do I use it? What functions?

Thanks!

Share this post


Link to post
Share on other sites
glTexImage2D(GL_TEXTURE_2D, 0, type_internal, texture->width, texture->height, 0, type_of_data, GL_UNSIGNED_BYTE, texture->imageData)
where types are GL_RGB or GL_RGBA in yor case

if you want 32bit texture set internal format to rgba; type_of_data should be set dependant on what texture you support

if more info needed, go for:
http://www.opengl.org/documentation/specs/version1.1/glspec1.1/node79.html

hope this helps,
Yan

Share this post


Link to post
Share on other sites
Thank you guys so much! This fixed it.
What do I do without you?

And I noticed you talked about "internal image format", sorry I didn't understand how that was connected to anything. Now I do =)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement