Jump to content
  • Advertisement
Sign in to follow this  
EternityZA

OpenGL issue with blending

This topic is 3763 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

this seems like a simple question but no amount of googling has solved this for me. looking at NeHe lesson 8 at the point where it explains the glColor4f method it states that the last parameter indicates the amount of transparancy (0.0 being completely transparent and 1.0 not being transparant at all) but no matter what i do i cant get any of my polygons to be completely opaque, changing the value used in the nehe example from 0.5 to 1.0 doesnt seem to be doing much... is it maybe because the nehe tuts are outdated or does it have anything to do with the fact that im using the jogl wrapper with Java, or am i just missing sumthing obvious. im a somewhat experienced java developer but im completely new to OpenGL

Share this post


Link to post
Share on other sites
Advertisement
If you want opaque object, simply disable blending using glDisable(GL_BLEND); and when you want to enable it again use glEnable(GL_BLEND); Anyway before finishing rendering blending should be disabled.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!