Jump to content
  • Advertisement
Sign in to follow this  
Lode

Toolbox window in Visual Studio 2005

This topic is 3905 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

There are many useful windows in VS2005, which are dockable. If you hide such a window, it stays hidden, if it's not hidden you can choose to dock it on one of the sides. They all work fine, except one: The Toolbox window. This window has three annoying properties: 1) It always takes its own space. This decreases the size remaining for your C++ code or place for tabs of other windows. 2) If you hide it, it'll always come back: whenever you open a resource in the resource editor (e.g. a dialog to edit, ...) when none was open yet, this window comes back. Always. Nothing to do against it. The other VS2005 windows don't come back all the time, only this Toolbox one. 3) It contains nothing useful. So this window is an annoying space waste that decreases the size of the area where you see the code, does nothing useful, and always comes back if you close it. If you "auto-hide" it, it comes in a bar on the right that also takes place and does an annoying "appearing" animation when you move the mouse over it (to go to the other screen), so that's also not an option. The solution I have been using for a year is this: I have dragged the window to the left side of the screen and gave it the smallest size possible, so now it's nothing more than a row of 1 or 2 pixels thick and 32 or so pixels high on the left side of the screen. Luckily VS2005 remembers the position of all its windows so this Toolbox window has remained at that unintrusive position for most of the last year, with a few times it jumping back but after dragging it back it remains there for months again. VS2005 users out there: have you ever noticed the existance of the Toolbox window? Ever wanted to close it only to find that it comes back when opening a resource? Have you found any solution to hide it forever? [Edited by - Lode on April 3, 2008 4:53:59 AM]

Share this post


Link to post
Share on other sites
Advertisement
Erm, on my computer the toolbox window of VS2005 stays closed and never pops back... As expected :/
Try to autohide it, but on another place, if you dont want to be disturbed (for example, dock it near the build and output windows, it will be hidden there)

[Edited by - rolkA on April 4, 2008 10:42:25 AM]

Share this post


Link to post
Share on other sites
Quote:
Original post by rolkA
Erm, on my computer the toolbox window of VS2005 stays closed... As expected :/


Even if you open a dialog to edit in Resource View?

Share this post


Link to post
Share on other sites
Well of course, it pops up when you edit a MFC dialog resource, sorry I thought you were talking about DotNet files. But it's usefull, since there are components in it, to create your dialog. Or I miss something ?

Same behavior in VS2008, I just tried.

[Edited by - rolkA on April 4, 2008 10:00:06 AM]

Share this post


Link to post
Share on other sites
That tool is very useful. Sounds like your are a noob with visual studios.

But to totally disable it you have to tell studios that you dont want it for resources Go to options turn its association off or change it to something else.

When doing mfc or gui's system that came with studio (like .net and the otheres if there is any.) It holds some tools for dialogs like buttons, containers, and other useful components. Studios call this design mode because you simply drag drop and position the items give you what you are expected to see in most cases

Share this post


Link to post
Share on other sites
I think I finally understand... He might want to always edit manually those resource files, and when you do this, the toobox window pops up, with nothing in it... Here is the problem.
So Lode, if you are doing this, then you dont need Visual Studio capabilities... You only need the text editor.

So, if you are ALWAYS doing this, you can change the association :
- right clic on an .rc file
- select "open with"
- select "source editor", and press "set as default"
- press Ok
Next time you will open an .rc file, it will be opened in the editor, without any disturbing toolbox window ;-)

Share this post


Link to post
Share on other sites
Quote:
Original post by Lode
If you "auto-hide" it, it comes in a bar on the right that also takes place and does an annoying "appearing" animation when you move the mouse over it...

You can configure the speed with which VS animates things. In the "Options" dialog, you would select the "General" node under "Environment", then set the slider that reads, "Animate environment tools."

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!