Sign in to follow this  
rookie1984

Lua and linker warning 4098

Recommended Posts

rookie1984    122
Hi a few friends and me are working on a game engine. We agreed to use Lua in our project. But, as soon as I added Lua 5.1.3 static library a warning popped up: warning LNK4098: defaultlib 'LIBCMT' conflicts with use of other libs; use /NODEFAULTLIB:library we are using Visual Studio 2005, C++. The code that uses the static library is compiled into a dll, which is used in a client program. Also, we aren't using any other third party libraries except DirectX. Has anyone had a similar experience? Or knows what this means and/or how to solve it? Thank you

Share this post


Link to post
Share on other sites
Gage64    1235
This seems to be a common problem. I don't know what causes it, but you can get rid of it by going to Project -> Properties -> Linker -> Input, and under Ignore Specific Library, write down "msvcrt.lib".

Share this post


Link to post
Share on other sites
Scourage    1198
looks like the lua library is compiled against a different runtime library than your application. Make sure that all your projects (and 3rd party libraries) are compiled with the same settings under code generation. Settings such as single threaded DLL, multi-threaded DLL, debug DLLL,

cheers,

Bob

Share this post


Link to post
Share on other sites
Sneftel    1788
Quote:
Original post by Gage64
This seems to be a common problem. I don't know what causes it, but you can get rid of it by going to Project -> Properties -> Linker -> Input, and under Ignore Specific Library, write down "msvcrt.lib".

That doesn't get rid of it. Just the opposite. It hides it, leaving it around to cause difficult-to-debug memory problems later on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this