Jump to content
  • Advertisement

This topic is 3709 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

We use the main functions with return 0(hardcoded retun value). Sometimes the main functions instead of returning 0 would return a negative value such as -1073741819. We use WIN 2003 as the environment and the development environment in MS VISUAL STUDIO 7.1. Please let me know if any one is acquainted with this problem and knows a ready made solution. Thanks & Regards, RohiniChandra

Share this post


Link to post
Share on other sites
Advertisement
I recently discover that simply returning 0 would not stop the program (yeah, very disturbing... -a program on linux, writen with gcc, using sdl-)
Instead of reterning 0, calling exit(0) was the thing to do. Maybe you could try this.

Share this post


Link to post
Share on other sites
Quote:
Original post by davidsporn
I recently discover that simply returning 0 would not stop the program (yeah, very disturbing... -a program on linux, writen with gcc, using sdl-)
Instead of reterning 0, calling exit(0) was the thing to do. Maybe you could try this.


"The brakes seem to be malfunctioning. Oh well, if you need to stop, just crash into a tree."

The proper question would be, why isn't it stopping? Spurious threads running? Some third-party library mis-behaving? My guess would be that SDL isn't properly shut down.

Share this post


Link to post
Share on other sites
SDL surely is involved, but I could'nt find what to do more after SDL_Quit().

Plus some sample code I was refering to called exit()...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!