Sign in to follow this  
bobsaget

A perplexing error(Me/vs 2005/and a header file)

Recommended Posts

I was looking at other apis thanks to the last post and answers and decided to use some code from some free tutorials to try out. I used the opengl free book from opengl.org and used some of the code. I ran into an odd error though. When I would type in the header files #include <GL/glu.h> #include <GL/glut.h> #include <stdlib.h> #include <GL/gl.h> and debugged it gave me something I haven't seen before. It started throwing 100's of error messages at the gl.h file instead of the main project. Even removing the #include directory for it wouldn't stop it from debugging this file. Another time it gave error messages for the stdlib.h directory. What should I do? last time this happened when it only debugged a .h file it some how later stopped and allowed the program to continue. Thanks

Share this post


Link to post
Share on other sites
The GL headers use things like function calling convention identifiers that are defined in windows.h, but don't actually include windows.h themselves. So in order for them to compile correctly, you need to include windows.h first. Don't ask me why the GL headers don't include windows.h, because I don't know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this