Jump to content
  • Advertisement
Sign in to follow this  
Eldritch

OpenGL Problem with eglSwapInterval

This topic is 3789 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm using OpenGL ES in my Windows Mobile 6 application, and I wanted to enable vertical sync by using eglSwapInterval. The parameters I supply are: #1: m_display (a valid GLDisplay variable, created in prior steps) #2: 1 (the update interval) But the eglSwapInterval function returns GL_FALSE. I even tried changing the second parameter to 0, just to try turning vsync off, but that resulted in the same return value. I have not made anything special to the config attributes involving EGL_MAX_SWAP_INTERVAL or EGL_MIN_SWAP_INTERVAL. Do I need to declare these in the attributes, or do they simply use the default value (GL_DONT_CARE)?

Share this post


Link to post
Share on other sites
Advertisement
I'm not an expert with GL|ES but there is the forum over at khronos.org

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!