Jump to content
  • Advertisement
Sign in to follow this  
devronious

Vista and my solution?

This topic is 3815 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ever since I upgraded to Vista64 I get an error when I try to run my app or debug it. It some "BadImageFormatException was unhandled". Anybody know what this is about and how to fix it?

Share this post


Link to post
Share on other sites
Advertisement
You're probably trying to use a 32 bit DLL. Change your platform from Any CPU to x86 to force your app to run in 32 bit mode.

Share this post


Link to post
Share on other sites
Quote:
Original post by Promit
You're probably trying to use a 32 bit DLL. Change your platform from Any CPU to x86 to force your app to run in 32 bit mode.


Can Vista not use 32-bit dlls in 64-bit apps ? I thought it was only 16-bit code that was out of the question ?

Edit: Then again now that I think about it, passing parameters on the stack might be messed up if 64-bit code was calling 32-bit dlls- given the different stack word size..

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!