Sign in to follow this  

Failed linker to d3dx9

This topic is 3494 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I got a failed linker weird tho the directory is linked to Dxsdk/lib where d3dx9 is, I'm linked through DXSDK in visual studio and the project file itselfmaybe I did something wrong? PlatformSDK was not needed Im using the DirectX 9 SDK, with Visual Studio Express Edition 2008: this is my problem Linking... LINK : fatal error LNK1104: cannot open file 'd3dx9.lib' Build log was saved at "file://c:\Documents and Settings\Main\My Documents\Visual Studio 2008\Projects\FUCK\DX\Debug\BuildLog.htm" DX - 1 error(s), 0 warning(s) ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ========== --------------------------------------------------------------------- Here is how I linked to visual studio 2008 tools->options->VC++ Directories->added: dxsdk\include added: dxsdk\lib heres how I linked to my project file DX Project->DXProperties->ConfigurationProperties->C\C++->general->additional include directories->added: dxsdk\include added: dxsdk\lib -------------------------------------------------------------------- this are the include packages #include <windows.h> //#include <windowsx.h> #include <d3d9.h> #include <d3dx9.h> ------------------------------ Heres the lib includes #pragma comment (lib, "d3d9.lib") #pragma comment (lib, "d3dx9.lib") -------------------------------------- I looked through every possible way, maybe im using the wrong studio with dx 9 or something, please help me [Edited by - steven31dd on May 26, 2008 1:47:57 PM]

Share this post


Link to post
Share on other sites
As the poster above said, it's \lib\x86. Though, you still need to specify the path to it, or to be generic you can use the environment variable which will always point to the most recent installation.

"$(DXSDK_DIR)Include";
"$(DXSDK_DIR)Lib\x86";

Share this post


Link to post
Share on other sites
<offtopic>
You can delete your 4 other topics by the same name here (which I'm assuming and hoping were accidental) by going to edit the individual posts, clicking the Checkbox: "[x] Delete? To delete this post, check this box.", right above username/password/subject, then hitting the Make Modifications button. If the topic hasn't received any replies, this should remove the extra threads entirely.

I'm a little curious how this accidentally happened over a 2 hours spread, I must admit.
</offtopic>

Share this post


Link to post
Share on other sites

This topic is 3494 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this