Jump to content
  • Advertisement
Sign in to follow this  
CmpDev

Mac GCC 4.0 error

This topic is 3664 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am emulating mac machine running Tiger OS on pearpc yet I am getting an error which I do not know how to fix (besides ungrading gcc),the following reproduces the error when compiled with "-ansi -pedantic"
#include <stdexcept>
int main(){}


The error is from file limits and is "error floating constant exceeds range of 'double' .Anybody have any ideas? Thanks

Share this post


Link to post
Share on other sites
Advertisement
I have a real Mac machine (Intel) with Mac OS X 10.4.11 and gcc 4.0.1, and I can't reproduce the problem. Are you sure your gcc installation is correct?

EDIT: Never mind. I just saw that PearPC is a PowerPC emulator, so my test isn't very relevant.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!